summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-06-29 16:32:26 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-06-29 16:53:14 -0400
commit4e48f39b336f9535c3bbf03e043f4a50370fbd1b (patch)
treebf99407efde48a829936fa031faea4a11643feef /games-board/camato
parentgames-rpg/egoboo: add .desktop icon, EAPI 7->8 (diff)
downloadgentoo-4e48f39b336f9535c3bbf03e043f4a50370fbd1b.tar.gz
gentoo-4e48f39b336f9535c3bbf03e043f4a50370fbd1b.tar.bz2
gentoo-4e48f39b336f9535c3bbf03e043f4a50370fbd1b.zip
games-board/camato: fix crash on keyboard events
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-board/camato')
-rw-r--r--games-board/camato/camato-0.7.4-r2.ebuild (renamed from games-board/camato/camato-0.7.4-r1.ebuild)4
-rw-r--r--games-board/camato/files/camato-0.7.4-implicit-string.patch8
2 files changed, 12 insertions, 0 deletions
diff --git a/games-board/camato/camato-0.7.4-r1.ebuild b/games-board/camato/camato-0.7.4-r2.ebuild
index 92df74471f24..7dc2af199883 100644
--- a/games-board/camato/camato-0.7.4-r1.ebuild
+++ b/games-board/camato/camato-0.7.4-r2.ebuild
@@ -18,6 +18,10 @@ KEYWORDS="~amd64 ~x86"
ruby_add_rdepend dev-ruby/ruby-gtk2
+PATCHES=(
+ "${FILESDIR}"/${P}-implicit-string.patch
+)
+
all_ruby_prepare() {
# this is really single target, but ruby-single is too limited
local ruby=$(ruby_get_use_implementations)
diff --git a/games-board/camato/files/camato-0.7.4-implicit-string.patch b/games-board/camato/files/camato-0.7.4-implicit-string.patch
new file mode 100644
index 000000000000..e631b07a87a8
--- /dev/null
+++ b/games-board/camato/files/camato-0.7.4-implicit-string.patch
@@ -0,0 +1,8 @@
+Crashes on keyboard events otherwise.
+--- a/map.rb
++++ b/map.rb
+@@ -35,3 +35,3 @@
+ if i < 0 or i > 255 then i = 0 end
+- my_str[0] = i
++ my_str[0] = i.to_s
+ set_resource(my_str)