summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2019-03-24 17:15:23 +0000
committerJames Le Cuirot <chewi@gentoo.org>2019-03-24 17:15:57 +0000
commit2187df4e2a89e7e13984ed149a2bfc3a6b22552e (patch)
tree098e2698483b77c0dd6f57b9648dce8b98f3937b /games-board/cockatrice/cockatrice-20190304-r1.ebuild
parentsys-fs/squashfs-tools: Also remove newly-added vulnerable ebuilds (diff)
downloadgentoo-2187df4e2a89e7e13984ed149a2bfc3a6b22552e.tar.gz
gentoo-2187df4e2a89e7e13984ed149a2bfc3a6b22552e.tar.bz2
gentoo-2187df4e2a89e7e13984ed149a2bfc3a6b22552e.zip
games-board/cockatrice: Build static libraries rather than shared
Closes: https://bugs.gentoo.org/681664 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-board/cockatrice/cockatrice-20190304-r1.ebuild')
-rw-r--r--games-board/cockatrice/cockatrice-20190304-r1.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/games-board/cockatrice/cockatrice-20190304-r1.ebuild b/games-board/cockatrice/cockatrice-20190304-r1.ebuild
new file mode 100644
index 000000000000..f44fa453f6d8
--- /dev/null
+++ b/games-board/cockatrice/cockatrice-20190304-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+MY_PV="2019-03-04-Release-2.7.0"
+DESCRIPTION="An open-source multiplatform software for playing card games over a network"
+HOMEPAGE="https://github.com/Cockatrice/Cockatrice"
+SRC_URI="${HOMEPAGE}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+client +oracle server"
+
+RDEPEND="
+ dev-qt/qtconcurrent:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtwebsockets:5
+ dev-qt/qtwidgets:5
+ client? (
+ dev-libs/protobuf:=
+ dev-qt/qtmultimedia:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsvg:5
+ )
+ oracle? ( sys-libs/zlib )
+ server? (
+ dev-libs/protobuf:=
+ dev-qt/qtsql:5
+ dev-qt/qtwebsockets:5
+ )
+"
+BDEPEND="
+ dev-qt/linguist-tools:5
+ client? ( dev-libs/protobuf )
+ server? ( dev-libs/protobuf )
+"
+DEPEND="${RDEPEND}
+"
+
+# As the default help/about display the sha1 we need it
+SHA1='294b433'
+
+S="${WORKDIR}/Cockatrice-${MY_PV}"
+
+PATCHES=(
+ "${FILESDIR}"/use-ccache.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=OFF
+ -DUSE_CCACHE=OFF
+ -DWITH_CLIENT=$(usex client)
+ -DWITH_ORACLE=$(usex oracle)
+ -DWITH_SERVER=$(usex server)
+ -DICONDIR="${EPREFIX}/usr/share/icons"
+ -DDESKTOPDIR="${EPREFIX}/usr/share/applications" )
+
+ # Add date in the help about, come from git originally
+ sed -e 's/^set(PROJECT_VERSION_FRIENDLY.*/set(PROJECT_VERSION_FRIENDLY \"'${SHA1}'\")/' \
+ -i cmake/getversion.cmake || die "sed failed!"
+
+ cmake-utils_src_configure
+}