summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-11-09 22:00:02 +0100
committerPacho Ramos <pacho@gentoo.org>2015-11-09 22:50:42 +0100
commite65b916352dd0b6a3e58f82a75734758ba794642 (patch)
tree58001be0a20ae92c221e5511cb4f3d1e03c079dd /games-board/gnome-mines/gnome-mines-3.18.2.ebuild
parentgames-puzzle/swell-foop: Drop old (diff)
downloadgentoo-e65b916352dd0b6a3e58f82a75734758ba794642.tar.gz
gentoo-e65b916352dd0b6a3e58f82a75734758ba794642.tar.bz2
gentoo-e65b916352dd0b6a3e58f82a75734758ba794642.zip
games-board/gnome-mines: Version bump
Package-Manager: portage-2.2.24
Diffstat (limited to 'games-board/gnome-mines/gnome-mines-3.18.2.ebuild')
-rw-r--r--games-board/gnome-mines/gnome-mines-3.18.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/games-board/gnome-mines/gnome-mines-3.18.2.ebuild b/games-board/gnome-mines/gnome-mines-3.18.2.ebuild
new file mode 100644
index 000000000000..adab7c3da0a2
--- /dev/null
+++ b/games-board/gnome-mines/gnome-mines-3.18.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.22"
+
+inherit gnome-games vala
+
+DESCRIPTION="Clear hidden mines from a minefield"
+HOMEPAGE="https://wiki.gnome.org/Apps/Mines"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.40:2
+ >=gnome-base/librsvg-2.32.0
+ >=x11-libs/gtk+-3.12:3
+"
+RDEPEND="${COMMON_DEPEND}
+ !<x11-themes/gnome-themes-standard-3.14
+"
+DEPEND="${COMMON_DEPEND}
+ $(vala_depend)
+ app-text/yelp-tools
+ dev-libs/appstream-glib
+ >=dev-util/intltool-0.50
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ gnome-games_src_prepare
+ vala_src_prepare
+}