summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-09-07 13:41:29 -0500
committerAustin English <wizardedit@gentoo.org>2016-09-07 13:41:29 -0500
commit6d31a59a75324eacf41c7840a0c44648c3e33c18 (patch)
tree5db8b95d8f3347d096f82a75da1199747f93628d /games-board/gtkatlantic/gtkatlantic-0.6.1-r1.ebuild
parentgames-board/gtkboard: remove deprecated games eclass (diff)
downloadgentoo-6d31a59a75324eacf41c7840a0c44648c3e33c18.tar.gz
gentoo-6d31a59a75324eacf41c7840a0c44648c3e33c18.tar.bz2
gentoo-6d31a59a75324eacf41c7840a0c44648c3e33c18.zip
games-board/gtkatlantic: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-board/gtkatlantic/gtkatlantic-0.6.1-r1.ebuild')
-rw-r--r--games-board/gtkatlantic/gtkatlantic-0.6.1-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/games-board/gtkatlantic/gtkatlantic-0.6.1-r1.ebuild b/games-board/gtkatlantic/gtkatlantic-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..fdfb15e665e8
--- /dev/null
+++ b/games-board/gtkatlantic/gtkatlantic-0.6.1-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools eutils gnome2-utils
+
+DESCRIPTION="Monopoly-like game that works with the monopd server"
+HOMEPAGE="http://gtkatlantic.gradator.net/"
+SRC_URI="http://download.tuxfamily.org/gtkatlantic/downloads/v0.6/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/libxml2
+ media-libs/libpng:0
+ x11-libs/gtk+:3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-warnings.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i -e 's:$(datadir):/usr/share:' {,data/}Makefile.am || die
+ sed -i -e 's/configure.in/configure.ac/' configure.in || die
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-icons-path=/usr/share/icons/hicolor
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}