summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-board/natch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-board/natch')
-rw-r--r--games-board/natch/Manifest1
-rw-r--r--games-board/natch/files/natch-2.4-format.patch29
-rw-r--r--games-board/natch/metadata.xml5
-rw-r--r--games-board/natch/natch-2.4.ebuild31
4 files changed, 66 insertions, 0 deletions
diff --git a/games-board/natch/Manifest b/games-board/natch/Manifest
new file mode 100644
index 000000000000..fcaf89455048
--- /dev/null
+++ b/games-board/natch/Manifest
@@ -0,0 +1 @@
+DIST Natch-2.4.tar.gz 196621 SHA256 866a5df290b1a1b6dd79c04d1239105fab4ff1fcd56e242655355f2ca04da47c SHA512 390b1cb295f6d8f4d5ec27abad9aae0c06ea1b4bb9c29dcf5bf74f515ac4a90926a657fe3dd3cc91233cf772d2f072cdc34a043e5e294dc668ca619b21535d81 WHIRLPOOL 5d61f019fb54711230fe2329de685cca7eaec289b53d1c40b3d1c116f6fbc04162266734ba57fc9ddde7ade99f1d9fe5f9d06c36dec7721ade6c127c494a90ef
diff --git a/games-board/natch/files/natch-2.4-format.patch b/games-board/natch/files/natch-2.4-format.patch
new file mode 100644
index 000000000000..cc2b3207c3b0
--- /dev/null
+++ b/games-board/natch/files/natch-2.4-format.patch
@@ -0,0 +1,29 @@
+--- src/pcpjtool.c.old 2014-10-17 08:38:21.547119790 +0200
++++ src/pcpjtool.c 2014-10-17 08:42:04.949035648 +0200
+@@ -45,7 +45,7 @@
+ int nb_libre = 0;
+ const char* separation_line = "+---+---+---+---+---+---+---+---+\n";
+
+- fprintf( MainFD, separation_line );
++ fprintf( MainFD, "%s", separation_line );
+ for (i=7; i>=0; i--)
+ {
+ fputc( '|', MainFD );
+@@ -94,7 +94,7 @@
+ fputc( '|', MainFD );
+ }
+ fputc('\n', MainFD);
+- fprintf( MainFD, separation_line );
++ fprintf( MainFD, "%s", separation_line );
+ if (nb_libre)
+ {
+ forsythe[nb_forsythe] = '0' + nb_libre;
+@@ -224,7 +224,7 @@
+ {
+ char s[12];
+
+- fprintf(MainFD, move_to_string(coup, s));
++ fprintf(MainFD, "%s", move_to_string(coup, s));
+ }
+
+ void
diff --git a/games-board/natch/metadata.xml b/games-board/natch/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-board/natch/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-board/natch/natch-2.4.ebuild b/games-board/natch/natch-2.4.ebuild
new file mode 100644
index 000000000000..0843d1c461ea
--- /dev/null
+++ b/games-board/natch/natch-2.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+MY_P="Natch-${PV}"
+DESCRIPTION="A program to solve chess proof games"
+HOMEPAGE="http://natch.free.fr/Natch.html"
+SRC_URI="http://natch.free.fr/Natch/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-format.patch
+}
+
+src_install() {
+ newgamesbin src/Natch natch
+ dodoc AUTHORS ChangeLog NEWS README THANKS example.txt
+ prepgamesdirs
+}