summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-04 06:56:39 +0000
committerSam James <sam@gentoo.org>2021-04-04 07:21:43 +0000
commitecd102c35a753b734f72d48ee61c048b806da760 (patch)
treee9515f7fc534ac829c99d591213b490b5ef21a8d /games-board/openyahtzee
parentgames-fps/tenebrae: port to EAPI 7, eutils-- (diff)
downloadgentoo-ecd102c35a753b734f72d48ee61c048b806da760.tar.gz
gentoo-ecd102c35a753b734f72d48ee61c048b806da760.tar.bz2
gentoo-ecd102c35a753b734f72d48ee61c048b806da760.zip
games-board/openyahtzee: port to EAPI 7, eutils--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-board/openyahtzee')
-rw-r--r--games-board/openyahtzee/openyahtzee-1.9.3.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/games-board/openyahtzee/openyahtzee-1.9.3.ebuild b/games-board/openyahtzee/openyahtzee-1.9.3.ebuild
index def1007cccb9..dbf5ebc9bb89 100644
--- a/games-board/openyahtzee/openyahtzee-1.9.3.ebuild
+++ b/games-board/openyahtzee/openyahtzee-1.9.3.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
WX_GTK_VER="3.0"
-inherit eutils flag-o-matic wxwidgets toolchain-funcs versionator
+inherit flag-o-matic toolchain-funcs wxwidgets
DESCRIPTION="A full-featured wxWidgets version of the classic dice game Yahtzee"
HOMEPAGE="http://openyahtzee.sourceforge.net/"
@@ -12,19 +13,19 @@ SRC_URI="mirror://sourceforge/openyahtzee/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
RDEPEND="x11-libs/wxGTK:${WX_GTK_VER}[X]"
-DEPEND="${RDEPEND}
- >=sys-devel/gcc-4.6
- dev-libs/boost"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/boost
+"
pkg_pretend() {
local ver=4.6
local msg="You need at least GCC ${ver}.x for C++11 range-based 'for' and nullptr support."
if tc-is-gcc ; then
- if ! version_is_at_least ${ver} $(gcc-version); then
+ if ver_test ${ver} -gt $(gcc-version); then
die ${msg}
fi
else