summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-08-11 21:12:08 +0200
committerDavid Seifert <soap@gentoo.org>2019-08-11 21:12:08 +0200
commitce5832b57c718f259d4cbaf00e2e9f5128d0d70f (patch)
tree0439782c464ec2e41cc7b869bf910b653dd8833a /games-board/pokerth/pokerth-1.1.2.ebuild
parentgames-board/pokerth: Unbundle dev-cpp/websocketpp (diff)
downloadgentoo-ce5832b57c718f259d4cbaf00e2e9f5128d0d70f.tar.gz
gentoo-ce5832b57c718f259d4cbaf00e2e9f5128d0d70f.tar.bz2
gentoo-ce5832b57c718f259d4cbaf00e2e9f5128d0d70f.zip
games-board/pokerth: Port to EAPI 7
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-board/pokerth/pokerth-1.1.2.ebuild')
-rw-r--r--games-board/pokerth/pokerth-1.1.2.ebuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/games-board/pokerth/pokerth-1.1.2.ebuild b/games-board/pokerth/pokerth-1.1.2.ebuild
index 685ac05c300b..c133c4056446 100644
--- a/games-board/pokerth/pokerth-1.1.2.ebuild
+++ b/games-board/pokerth/pokerth-1.1.2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit desktop gnome2-utils qmake-utils
+inherit desktop qmake-utils xdg
DESCRIPTION="Texas Hold'em poker game"
HOMEPAGE="https://www.pokerth.net/"
@@ -47,7 +47,7 @@ PATCHES=(
)
src_prepare() {
- default
+ xdg_src_prepare
sed -i 's/!client//' *.pro || die
# delete bundled dev-cpp/websocketpp to be safe
@@ -73,7 +73,3 @@ src_install() {
doicon -s 128 ${PN}.png
fi
}
-
-pkg_preinst() { gnome2_icon_savelist; }
-pkg_postinst() { gnome2_icon_cache_update; }
-pkg_postrm() { gnome2_icon_cache_update; }