summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-02-11 13:51:44 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-02-11 18:13:56 -0500
commita27c1aa6342e1df6780a8f64ad28cbee452841b8 (patch)
tree49cabcac883f6b32dcf9bb84c3d05b7f099703f3 /games-board/pychess
parentgames-misc/doge: modernize and enable py3.10 (diff)
downloadgentoo-a27c1aa6342e1df6780a8f64ad28cbee452841b8.tar.gz
gentoo-a27c1aa6342e1df6780a8f64ad28cbee452841b8.tar.bz2
gentoo-a27c1aa6342e1df6780a8f64ad28cbee452841b8.zip
games-board/pychess: modernize and enable py3.10
Upstream doesn't advertise support for 3.10 yet, but no known issues/reports and seems to run fine. Also add several missing [introspection] based on gi.require_version() statements, and roughly update description (upstream no longer advertises this as "for GNOME", not that there's much else to say). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-board/pychess')
-rw-r--r--games-board/pychess/files/pychess-1.0.3-setuptools-warning.patch8
-rw-r--r--games-board/pychess/pychess-1.0.3-r1.ebuild47
2 files changed, 55 insertions, 0 deletions
diff --git a/games-board/pychess/files/pychess-1.0.3-setuptools-warning.patch b/games-board/pychess/files/pychess-1.0.3-setuptools-warning.patch
new file mode 100644
index 000000000000..414a486905b9
--- /dev/null
+++ b/games-board/pychess/files/pychess-1.0.3-setuptools-warning.patch
@@ -0,0 +1,8 @@
+Silence QA notice for:
+dist.py:275: UserWarning: Unknown distribution option: 'executables'
+--- a/setup.py
++++ b/setup.py
+@@ -323,3 +323,2 @@
+ "bdist_msi": bdist_msi_options},
+- executables=executables
+ )
diff --git a/games-board/pychess/pychess-1.0.3-r1.ebuild b/games-board/pychess/pychess-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..f80647c3668a
--- /dev/null
+++ b/games-board/pychess/pychess-1.0.3-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite"
+inherit distutils-r1 xdg
+
+DESCRIPTION="GTK chess client"
+HOMEPAGE="https://pychess.github.io/"
+SRC_URI="https://github.com/pychess/pychess/releases/download/${PV}/${P}.tar.gz"
+S="${WORKDIR}/PyChess-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gstreamer"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP},sqlite]
+ dev-python/websockets[${PYTHON_USEDEP}]
+ gstreamer? ( dev-python/gst-python:1.0[${PYTHON_USEDEP}] )')
+ gnome-base/librsvg:2[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/gtksourceview:3.0[introspection]
+ x11-libs/pango[introspection]
+ x11-themes/adwaita-icon-theme"
+BDEPEND="${RDEPEND}" # setup.py fails if introspection deps not found
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.3-setuptools-warning.patch
+)
+
+src_install() {
+ distutils-r1_src_install
+
+ # https://github.com/pychess/pychess/pull/1825
+ gunzip -v "${ED}"/usr/share/man/man1/${PN}.1.gz || die
+}