summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-11-11 13:35:49 +0100
committerPacho Ramos <pacho@gentoo.org>2021-11-11 13:59:12 +0100
commit0e806857be6223e399e889a5125c1d742ac00ccb (patch)
tree71774aaa3ee679315895030f37c146df9d406764 /games-board
parentgnome-extra/gnome-calendar: Bump to 41.1 (diff)
downloadgentoo-0e806857be6223e399e889a5125c1d742ac00ccb.tar.gz
gentoo-0e806857be6223e399e889a5125c1d742ac00ccb.tar.bz2
gentoo-0e806857be6223e399e889a5125c1d742ac00ccb.zip
games-board/gnome-chess: Bump to 41.1
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'games-board')
-rw-r--r--games-board/gnome-chess/Manifest1
-rw-r--r--games-board/gnome-chess/gnome-chess-41.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/games-board/gnome-chess/Manifest b/games-board/gnome-chess/Manifest
index f66934ed2585..5b6b4ee8647f 100644
--- a/games-board/gnome-chess/Manifest
+++ b/games-board/gnome-chess/Manifest
@@ -1 +1,2 @@
DIST gnome-chess-40.1.tar.xz 741168 BLAKE2B 3691f7aa03532456f9437588641417af4db45b99ffb0f211eca8dffd7a7ba7cf834c7f1e3e2cf6933df96c05b981edb7db3aac430be2c7256d96fca6ecb73db4 SHA512 aae1690724c068717045d70f4fbd5a6cf1fc169ae0bd5df0ae7f0d7a2609c93c482da545008dd3c5d11e975ec8f2c5fc6f4b0007a8f2a1128a75aec2f3fcb083
+DIST gnome-chess-41.1.tar.xz 615936 BLAKE2B 40a6f576fadd74777599192d7493f3a16abac45fc1a29c9a4e5cf1ec4d432e18910381bb26f9700b4585e1e395601d0b6a72b316139cfe74ecb6e33c9c4f001d SHA512 71d9b51599699c24d505eb4f120d99509c5e69c00d6aba1768029f9adf8ba70be6e40d001928f141a92852fb318d9f9b2ecb01b6bcbfecaf1408b89792b25224
diff --git a/games-board/gnome-chess/gnome-chess-41.1.ebuild b/games-board/gnome-chess/gnome-chess-41.1.ebuild
new file mode 100644
index 000000000000..ca0a04de6759
--- /dev/null
+++ b/games-board/gnome-chess/gnome-chess-41.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..10} )
+VALA_MIN_API_VERSION="0.52"
+
+inherit gnome.org gnome2-utils meson python-any-r1 readme.gentoo-r1 vala xdg
+
+DESCRIPTION="Play the classic two-player boardgame of chess"
+HOMEPAGE="https://wiki.gnome.org/Apps/Chess"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ gui-libs/gtk:4
+ >=gnome-base/librsvg-2.46.0:2
+"
+DEPEND="${RDEPEND}
+ gnome-base/librsvg:2[vala]
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ $(vala_depend)
+ dev-util/itstool
+ dev-libs/appstream-glib
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DOC_CONTENTS="To be able to play against a computer you will need
+to install a chess engine package, for example games-board/gnuchess"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}