summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-09-05 23:16:07 -0500
committerAustin English <wizardedit@gentoo.org>2016-09-05 23:16:07 -0500
commit27445d402c2e84284f26edc036ddedcc8403d8b6 (patch)
tree17ee44ad2bd155487db79c288487371d37eaaf7d /games-board
parentgames-board/pysolfc: fix USE=extra-cardsets not showing extra cardsets (diff)
downloadgentoo-27445d402c2e84284f26edc036ddedcc8403d8b6.tar.gz
gentoo-27445d402c2e84284f26edc036ddedcc8403d8b6.tar.bz2
gentoo-27445d402c2e84284f26edc036ddedcc8403d8b6.zip
games-board/pysolfc: remove 2.0-r4, broken, superceded by -r5
Package-Manager: portage-2.3.0
Diffstat (limited to 'games-board')
-rw-r--r--games-board/pysolfc/pysolfc-2.0-r4.ebuild80
1 files changed, 0 insertions, 80 deletions
diff --git a/games-board/pysolfc/pysolfc-2.0-r4.ebuild b/games-board/pysolfc/pysolfc-2.0-r4.ebuild
deleted file mode 100644
index c2ddc64c4e35..000000000000
--- a/games-board/pysolfc/pysolfc-2.0-r4.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="tk"
-DISTUTILS_SINGLE_IMPL="1"
-
-inherit eutils python-single-r1 distutils-r1
-
-MY_PN=PySolFC
-SOL_URI="mirror://sourceforge/${PN}"
-
-DESCRIPTION="An exciting collection of more than 1000 solitaire card games"
-HOMEPAGE="http://pysolfc.sourceforge.net/"
-SRC_URI="${SOL_URI}/${MY_PN}-${PV}.tar.bz2
- extra-cardsets? ( ${SOL_URI}/${MY_PN}-Cardsets-${PV}.tar.bz2 )"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="extra-cardsets minimal +sound"
-
-S=${WORKDIR}/${MY_PN}-${PV}
-
-DEPEND=""
-RDEPEND="${RDEPEND}
- !minimal? ( dev-python/pillow[tk,${PYTHON_USEDEP}]
- dev-tcltk/tktable )
- sound? ( dev-python/pygame[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- local PATCHES=(
- "${FILESDIR}/${PN}-PIL-imports.patch" #471514
- )
-
- distutils-r1_python_prepare_all
-}
-
-pkg_setup() {
- python-single-r1_pkg_setup
-}
-
-src_prepare() {
- default
- distutils-r1_src_prepare
-
- sed -i \
- -e "/pysol.desktop/d" \
- -e "s:share/icons:share/pixmaps:" \
- setup.py || die
-
- mv docs/README{,.txt} || die
-}
-
-src_compile() {
- distutils-r1_src_compile
-}
-
-python_install_all() {
- make_desktop_entry pysol.py "PySol Fan Club Edition" pysol02
-
- if use extra-cardsets; then
- insinto /usr/share/${PN}
- doins -r "${WORKDIR}"/${MY_PN}-Cardsets-${PV}/*
- fi
-
- doman docs/*.6
-
- DOCS=( README AUTHORS docs/README.txt docs/README.SOURCE )
- HTML_DOCS=( docs/*html )
-
- distutils-r1_python_install_all
-}
-
-src_install() {
- distutils-r1_src_install
-}