summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-09-24 03:15:13 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-09-24 03:25:50 -0400
commit279979df74300f60d3442126edc32b54f62d7323 (patch)
treea0c7d0bc21e66a20043c69cb996927614d0e5c65 /games-board
parentgames-board/phalanx: EAPI8, minor improvements (diff)
downloadgentoo-279979df74300f60d3442126edc32b54f62d7323.tar.gz
gentoo-279979df74300f60d3442126edc32b54f62d7323.tar.bz2
gentoo-279979df74300f60d3442126edc32b54f62d7323.zip
games-board/phalanx: tidy ebuild a bit more
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-board')
-rw-r--r--games-board/phalanx/phalanx-22-r1.ebuild24
1 files changed, 13 insertions, 11 deletions
diff --git a/games-board/phalanx/phalanx-22-r1.ebuild b/games-board/phalanx/phalanx-22-r1.ebuild
index 36eae23cc9df..4d2f1f020ea5 100644
--- a/games-board/phalanx/phalanx-22-r1.ebuild
+++ b/games-board/phalanx/phalanx-22-r1.ebuild
@@ -17,24 +17,26 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
src_compile() {
- # configure is not used in the project; confs are in Makefile,
- # and here we override them:
- local define="-DGNUFUN" myvar
- for myvar in "PBOOK" "SBOOK" "LEARN" ; do
- define="${define} -D${myvar}_DIR=\"\\\"${EPREFIX}/usr/share/${PN}\\\"\""
- done
- emake \
- DEFINES="${define}" \
- CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS}" \
+ local defines=(
+ -DGNUFUN
+ -D{PBOOK,SBOOK,LEARN}_DIR="'\"${EPREFIX}/usr/share/${PN}\"'"
+ )
+
+ local emakeargs=(
+ DEFINES="${defines[*]}"
+ CC="$(tc-getCC)"
+ CFLAGS="${CFLAGS}"
LDFLAGS="${LDFLAGS}"
+ )
+
+ emake "${emakeargs[@]}"
}
src_install() {
dobin phalanx
insinto /usr/share/${PN}
- doins pbook.phalanx sbook.phalanx learn.phalanx
+ doins {pbook,sbook,learn}.phalanx
einstalldocs
}