summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-08-04 13:57:56 -0500
committerAustin English <wizardedit@gentoo.org>2016-08-04 19:22:40 -0500
commit4de463410f1d3d8065cdd89f2a303918c8ed5692 (patch)
tree74ca2c3f80d2c1dff6ae2be6b2eca7cc3c3d7c2c /games-board
parentgames-board/mt_dolphin_ia: remove deprecated games eclass (diff)
downloadgentoo-4de463410f1d3d8065cdd89f2a303918c8ed5692.tar.gz
gentoo-4de463410f1d3d8065cdd89f2a303918c8ed5692.tar.bz2
gentoo-4de463410f1d3d8065cdd89f2a303918c8ed5692.zip
games-board/mt_gtk_client: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-board')
-rw-r--r--games-board/mt_gtk_client/files/mt_gtk_client-0.1.98-formatsecurity.patch4
-rw-r--r--games-board/mt_gtk_client/mt_gtk_client-0.1.98-r1.ebuild31
2 files changed, 33 insertions, 2 deletions
diff --git a/games-board/mt_gtk_client/files/mt_gtk_client-0.1.98-formatsecurity.patch b/games-board/mt_gtk_client/files/mt_gtk_client-0.1.98-formatsecurity.patch
index 869e0ea8220b..edf33585b810 100644
--- a/games-board/mt_gtk_client/files/mt_gtk_client-0.1.98-formatsecurity.patch
+++ b/games-board/mt_gtk_client/files/mt_gtk_client-0.1.98-formatsecurity.patch
@@ -1,5 +1,5 @@
---- src/player.c.old 2015-10-14 21:52:59.453971198 +0200
-+++ src/player.c 2015-10-14 21:53:36.375289009 +0200
+--- a/src/player.c 2015-10-14 21:52:59.453971198 +0200
++++ b/src/player.c 2015-10-14 21:53:36.375289009 +0200
@@ -52,7 +52,7 @@
{
player->nick[0] = g_string_new (config->gui_player_name->str);
diff --git a/games-board/mt_gtk_client/mt_gtk_client-0.1.98-r1.ebuild b/games-board/mt_gtk_client/mt_gtk_client-0.1.98-r1.ebuild
new file mode 100644
index 000000000000..b58f938149d1
--- /dev/null
+++ b/games-board/mt_gtk_client/mt_gtk_client-0.1.98-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="client for the french tarot game maitretarot"
+HOMEPAGE="http://www.nongnu.org/maitretarot/"
+SRC_URI="https://savannah.nongnu.org/download/maitretarot/${PN}.pkg/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome"
+
+DEPEND="dev-libs/glib:2
+ dev-libs/libxml2
+ dev-games/libmaitretarot
+ dev-games/libmt_client
+ gnome-base/libgnomeui
+ x11-libs/gtk+:2"
+RDEPEND="${DEPEND}
+ dev-games/cardpics"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-formatsecurity.patch
+)
+
+src_configure() {
+ econf $(use_enable gnome gnome2)
+}