summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-05-31 12:33:33 -0400
committerMatt Turner <mattst88@gentoo.org>2023-05-31 12:41:10 -0400
commit79ee53516493c3b5f3857ab41f251710a7c4e09c (patch)
treecc8d94f9e7b5a01cf60743ad14f98a4e0449b6e4 /games-board
parentdev-ruby/capistrano: add 3.17.3 (diff)
downloadgentoo-79ee53516493c3b5f3857ab41f251710a7c4e09c.tar.gz
gentoo-79ee53516493c3b5f3857ab41f251710a7c4e09c.tar.bz2
gentoo-79ee53516493c3b5f3857ab41f251710a7c4e09c.zip
games-board/gnome-mahjongg: Version bump to 3.40.0
Closes: https://bugs.gentoo.org/904476 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'games-board')
-rw-r--r--games-board/gnome-mahjongg/Manifest1
-rw-r--r--games-board/gnome-mahjongg/gnome-mahjongg-3.40.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/games-board/gnome-mahjongg/Manifest b/games-board/gnome-mahjongg/Manifest
index 4af599fae961..cd109529437d 100644
--- a/games-board/gnome-mahjongg/Manifest
+++ b/games-board/gnome-mahjongg/Manifest
@@ -1 +1,2 @@
DIST gnome-mahjongg-3.38.3.tar.xz 3061860 BLAKE2B c4ba84d2b5ebece56fc2de605c9572f10103323f0af9174538cb9124b617a3268c1c0fa27a5634c54b64188b7f1589ae6f14b02370de5edb44742c1b30553456 SHA512 883ed8e2cc6e5efa87adce2dab0843f8b76e4772174cdbe8a535dede714f486d8493058d822a7b8cccff50995d11f3b6cff25d5f77406e931aee5fd479f23bb5
+DIST gnome-mahjongg-3.40.0.tar.xz 3156788 BLAKE2B 3a8dd05001d75a7fa7663556dcad135b89786333c4c89ee131e7d63dafaee2a738f0c573199a69e6bc015036270a94c8be6cd6d48630faddba297710f48931d0 SHA512 9102d48d7a1cd2808a4de86cb3cb73c30bbe769bdc58f2a69914700218972a8c96cf18b5165cc20eb9a33866a70c5b2daee43cbecf758526d89a0b8720ef5c9a
diff --git a/games-board/gnome-mahjongg/gnome-mahjongg-3.40.0.ebuild b/games-board/gnome-mahjongg/gnome-mahjongg-3.40.0.ebuild
new file mode 100644
index 000000000000..c91e6e720399
--- /dev/null
+++ b/games-board/gnome-mahjongg/gnome-mahjongg-3.40.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Disassemble a pile of tiles by removing matching pairs"
+HOMEPAGE="https://wiki.gnome.org/Apps/Mahjongg"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.40.0:2
+ >=gui-libs/gtk-4.5.0:4
+ gui-libs/libadwaita:1
+ >=gnome-base/librsvg-2.46.0:2
+"
+DEPEND="${RDEPEND}
+ gnome-base/librsvg:2[vala]
+"
+BDEPEND="
+ $(vala_depend)
+ dev-libs/appstream-glib
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}