summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-27 21:19:15 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-03-07 19:58:55 +0100
commit815b23588ac6f65b34725fa7f67756fd297d1e10 (patch)
tree01e1dd56237fd62d316b95504b8a1ae1f2680f0a /games-board
parentsci-physics/reduze: Drop 2.2 (diff)
downloadgentoo-815b23588ac6f65b34725fa7f67756fd297d1e10.tar.gz
gentoo-815b23588ac6f65b34725fa7f67756fd297d1e10.tar.bz2
gentoo-815b23588ac6f65b34725fa7f67756fd297d1e10.zip
games-board/gambit: Switch to cmake.eclass, add missing desktop.eclass
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'games-board')
-rw-r--r--games-board/gambit/gambit-1.0.4-r1.ebuild22
1 files changed, 9 insertions, 13 deletions
diff --git a/games-board/gambit/gambit-1.0.4-r1.ebuild b/games-board/gambit/gambit-1.0.4-r1.ebuild
index fd20cc73c5d7..6831c153f763 100644
--- a/games-board/gambit/gambit-1.0.4-r1.ebuild
+++ b/games-board/gambit/gambit-1.0.4-r1.ebuild
@@ -1,23 +1,24 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
CMAKE_IN_SOURCE_BUILD=true
-inherit cmake-utils
-
MY_P="${P^}"
+inherit cmake desktop
DESCRIPTION="Qt-based chess application + engine \"gupta\""
HOMEPAGE="https://sourceforge.net/projects/gambitchess/"
SRC_URI="mirror://sourceforge/project/${PN}chess/${MY_P}/${MY_P}-src.tar.xz"
+S="${WORKDIR}/${MY_P}-src"
LICENSE="CC0-1.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="dev-qt/qtcore:5
+DEPEND="
+ dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5
dev-qt/qtopengl:5
@@ -26,11 +27,7 @@ DEPEND="dev-qt/qtcore:5
x11-libs/libX11"
RDEPEND="${DEPEND}"
-S="${WORKDIR}/${MY_P}-src"
-
-PATCHES=(
- "${FILESDIR}"/${P}-compile-flags.patch
-)
+PATCHES=( "${FILESDIR}"/${P}-compile-flags.patch )
src_configure() {
local mycmakeargs=(
@@ -38,12 +35,11 @@ src_configure() {
-DCONFIG_GUPTA_ENGINE_DIRECTORY=/usr/bin
-DCONFIG_RESOURCE_PATH_PREFIX=/usr/share/${PN}/
)
-
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
emake -C engine/gupta VERBOSE=1 STRIP=/bin/true CFLAGS_RELEASE= release
}