summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-12-28 09:43:07 -0500
committerIonen Wolkens <ionen@gentoo.org>2021-12-28 12:00:05 -0500
commit85b669dd1b733621b4a17f90bd8cd5d1fe2d4125 (patch)
treebafbefd4ffd1c6d69907974153309b43adc3dbfa /games-board
parentgames-action/abuse: add github remote-id (diff)
downloadgentoo-85b669dd1b733621b4a17f90bd8cd5d1fe2d4125.tar.gz
gentoo-85b669dd1b733621b4a17f90bd8cd5d1fe2d4125.tar.bz2
gentoo-85b669dd1b733621b4a17f90bd8cd5d1fe2d4125.zip
games-board/gnuchess: drop 6.2.8-r1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-board')
-rw-r--r--games-board/gnuchess/Manifest1
-rw-r--r--games-board/gnuchess/files/gnuchess-6.2.8-cve-2021-30184.patch72
-rw-r--r--games-board/gnuchess/gnuchess-6.2.8-r1.ebuild21
3 files changed, 0 insertions, 94 deletions
diff --git a/games-board/gnuchess/Manifest b/games-board/gnuchess/Manifest
index 86efcc4555b5..55fa4724363a 100644
--- a/games-board/gnuchess/Manifest
+++ b/games-board/gnuchess/Manifest
@@ -1,2 +1 @@
-DIST gnuchess-6.2.8.tar.gz 804080 BLAKE2B 7079c07ae7cd2f225c428a7bf14d53eec394382508544994918b87db35d5cbdeb9cf42a11f5bc2f9c0c7b778384d6cdb9aad4490bc9cfd40a513fc2e36cbdd67 SHA512 9146ee727c1eb8002eb3b1e762d71876b512eff0799eafec7019d5312766fe2bd6655c622e66f86e92f80d2f3666e48158a1245b42c30bd3221a8b379689ecdd
DIST gnuchess-6.2.9.tar.gz 802697 BLAKE2B e450e1d77f3158f2a063a7fc80985ad6d59f26a17a86aa9d18d86f32ee1c01fba100e59b02ea65276a1ee480ed050fbafd68635d40bae75205763fd34bfd608a SHA512 7e2ec9e14ab331ffaab2dd60da81b64b5c5a07cf14f9139d67c77886038512d15511939b8e683675ea6611e24ff2c38212a7f288540448c9225c263435f71963
diff --git a/games-board/gnuchess/files/gnuchess-6.2.8-cve-2021-30184.patch b/games-board/gnuchess/files/gnuchess-6.2.8-cve-2021-30184.patch
deleted file mode 100644
index dfa89a0e17c3..000000000000
--- a/games-board/gnuchess/files/gnuchess-6.2.8-cve-2021-30184.patch
+++ /dev/null
@@ -1,72 +0,0 @@
-From 7059e40c7a487b17886e1d345b52fc0cfca8df72 Mon Sep 17 00:00:00 2001
-From: Sebastian Pipping <sebastian@pipping.org>
-Date: Wed, 2 Jun 2021 13:15:29 +0200
-Subject: [PATCH] frontend/cmd.cc: Fix buffer overflow CVE-2021-30184
-
-Based on prior work by Michael Vaughan,
-with "break;" replaced by "return;" and
-magic number 9 resolved by strlen("setboard ").
-
-Mimics close-to-identical existing code from
-elsewhere in the the same file.
----
- src/frontend/cmd.cc | 30 ++++++++++++++++++++++--------
- 1 file changed, 22 insertions(+), 8 deletions(-)
-
-diff --git a/src/frontend/cmd.cc b/src/frontend/cmd.cc
-index a321fc2..394d03f 100644
---- a/src/frontend/cmd.cc
-+++ b/src/frontend/cmd.cc
-@@ -477,13 +477,20 @@ void cmd_pgnload(void)
- return;
- }
-
-- strcpy( data, "setboard " );
-+ const char setboardCmd[] = "setboard ";
-+ unsigned int setboardLen = strlen(setboardCmd);
-+ strcpy( data, setboardCmd );
- int i=0;
- while ( epdline[i] != '\n' ) {
-- data[i+9] = epdline[i];
-- ++i;
-+ if (i + setboardLen < MAXSTR - 1) {
-+ data[i+setboardLen] = epdline[i];
-+ ++i;
-+ } else {
-+ printf( _("Error reading contents of file '%s'.\n"), token[1] );
-+ return;
-+ }
- }
-- data[i+9] = '\0';
-+ data[i+setboardLen] = '\0';
- SetDataToEngine( data );
- SetAutoGo( true );
- pgnloaded = 0;
-@@ -501,13 +508,20 @@ void cmd_pgnreplay(void)
- return;
- }
-
-- strcpy( data, "setboard " );
-+ const char setboardCmd[] = "setboard ";
-+ unsigned int setboardLen = strlen(setboardCmd);
-+ strcpy( data, setboardCmd );
- int i=0;
- while ( epdline[i] != '\n' ) {
-- data[i+9] = epdline[i];
-- ++i;
-+ if (i + setboardLen < MAXSTR - 1) {
-+ data[i+setboardLen] = epdline[i];
-+ ++i;
-+ } else {
-+ printf( _("Error reading contents of file '%s'.\n"), token[1] );
-+ return;
-+ }
- }
-- data[i+9] = '\0';
-+ data[i+setboardLen] = '\0';
-
- SetDataToEngine( data );
- SetAutoGo( true );
---
-2.31.1
-
diff --git a/games-board/gnuchess/gnuchess-6.2.8-r1.ebuild b/games-board/gnuchess/gnuchess-6.2.8-r1.ebuild
deleted file mode 100644
index 8e08730283af..000000000000
--- a/games-board/gnuchess/gnuchess-6.2.8-r1.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="Console based chess interface"
-HOMEPAGE="https://www.gnu.org/software/chess/chess.html"
-SRC_URI="mirror://gnu/chess/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ppc64 x86"
-
-PATCHES=(
- "${FILESDIR}"/${P}-cve-2021-30184.patch # bug 780855
-)
-
-src_configure() {
- # bug #491088
- econf --without-readline
-}