summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2021-07-03 19:06:23 +0000
committerPatrick Lauer <patrick@gentoo.org>2021-07-03 19:06:41 +0000
commitad36939141dae40edbcce598c27b0b0cf8da23a6 (patch)
tree0699a0fe9a704017fe5c77be96e64282edcf0520 /games-board
parentnet-misc/xmrig: 6.13.1 version bump (diff)
downloadgentoo-ad36939141dae40edbcce598c27b0b0cf8da23a6.tar.gz
gentoo-ad36939141dae40edbcce598c27b0b0cf8da23a6.tar.bz2
gentoo-ad36939141dae40edbcce598c27b0b0cf8da23a6.zip
games-board/stockfish: Bump to 14
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'games-board')
-rw-r--r--games-board/stockfish/Manifest2
-rw-r--r--games-board/stockfish/stockfish-14.ebuild74
2 files changed, 76 insertions, 0 deletions
diff --git a/games-board/stockfish/Manifest b/games-board/stockfish/Manifest
index 52bdaa5c7f94..994f8aa25d84 100644
--- a/games-board/stockfish/Manifest
+++ b/games-board/stockfish/Manifest
@@ -1,3 +1,5 @@
DIST stockfish-10-src.zip 174377 BLAKE2B 58142b16f59f15773c8811d6e10588dbc680c94cd504d26f4ca285dbe632d845ede06571e501a4e2b77adbb9b00d91978236ff179a46a73dc9a03cfa1ae3490c SHA512 959c4f3c497ba3108884dabc38de824f11781ae57b4ab5fdf25daf9a7fc0326e663adb1c081b8c8d57a7bf5f2e941369502a50a0c93135a001c6bd1af360d0f8
DIST stockfish-13-nn-62ef826d1a6d.nnue 21022697 BLAKE2B 013396fec72e14dfb90ca308bdcbaf98f27b29feb03cb2c855f521dc33d0787de51812cb2a52e4aa94622120fc89a5f2302fd6296a4fb1db33e0de57156a41c3 SHA512 25a0a1b5c440fcfaa8ee122391fbb075e4b4e6bdacae816a2897bb346c0d5c459ae464fc7680414e87eadf2a5a00565d4f3ac2c559fea4bdddd1e4a38874fba7
DIST stockfish-13.tar.gz 181226 BLAKE2B ab6f2afccce2b4767c69d07c18aa611cb71388aae9b27e8a6c95b61db4a27c18b0e7a21aa30e10b4b56d018c1a4146dcea4896c4d68d7a9f297fa0758739ce9c SHA512 5ee6581b8324ed32f02ed0f1ea5df311635203e5f1806d00f9819ad076ef4082481f8ecebbb531154cbb120bb2b396c738c3ef2e2e6ee0fd6a5bd6ff88192706
+DIST stockfish-14-nn-3475407dc199.nnue 47721371 BLAKE2B e0d21fb2c282bb6c07a027474ba4c55d4ba993bd7e203a13eda034266c0d7004b9d7a5f6e68ce3209e0e9c71f52692a5e5124d93d10f2dd2ed034be389901023 SHA512 11774bd70a38a9df2b314ab19631a45139a75fcd7cf81fcc3bf5568505292d3f66bad4a2d5eff7f51e2f091995cc76107c6fb43fcfd6e0f8a6ee3ff6e59d72ab
+DIST stockfish-14.tar.gz 183879 BLAKE2B fd2fbcd37f90baf6b81432ebee7aa5b949c05253e04ec361fa502687de597e90aa6c85a90a5fd1baea52da423264d8e14853303564c3bc6f37bc98de890c5d3c SHA512 90025c0559d09f950732c051362711bed7f22e5495daeadf1ac8d7b1be9ede7e9aff80ca8755fccd95bdb48e2b2ea4b4355e02cd9112ac8e5eec457774289f34
diff --git a/games-board/stockfish/stockfish-14.ebuild b/games-board/stockfish/stockfish-14.ebuild
new file mode 100644
index 000000000000..b363cf44903e
--- /dev/null
+++ b/games-board/stockfish/stockfish-14.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Free UCI chess engine, claimed to be the strongest in the world"
+HOMEPAGE="https://stockfishchess.org/"
+
+NNUE_FILE="nn-3475407dc199.nnue"
+
+SRC_URI="https://github.com/official-stockfish/Stockfish/archive/sf_${PV}.tar.gz -> ${P}.tar.gz
+ https://tests.stockfishchess.org/api/nn/${NNUE_FILE} -> ${P}-${NNUE_FILE}"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cpu_flags_arm_v7 cpu_flags_x86_avx2 cpu_flags_x86_popcnt cpu_flags_x86_sse debug
+ general-32 general-64 +optimize"
+
+DEPEND="|| ( app-arch/unzip app-arch/zip )"
+RDEPEND=""
+
+S="${WORKDIR}/Stockfish-sf_${PV}/src"
+
+src_prepare() {
+ default
+
+ cp "${DISTDIR}"/${P}-${NNUE_FILE} ${NNUE_FILE} || die "copying the nnue file failed"
+
+ # prevent pre-stripping
+ sed -e 's:-strip $(BINDIR)/$(EXE)::' -i Makefile \
+ || die 'failed to disable stripping in the Makefile'
+}
+
+src_compile() {
+ local my_arch
+
+ # generic unoptimized first
+ use general-32 && my_arch=general-32
+ use general-64 && my_arch=general-64
+
+ # x86
+ use x86 && my_arch=x86-32-old
+ use cpu_flags_x86_sse && my_arch=x86-32
+
+ # amd64
+ use amd64 && my_arch=x86-64
+ use cpu_flags_x86_popcnt && my_arch=x86-64-modern
+
+ # both bmi2 and avx2 are part of hni (haswell new instructions)
+ use cpu_flags_x86_avx2 && my_arch=x86-64-bmi2
+
+ # other architectures
+ use cpu_flags_arm_v7 && my_arch=armv7
+ use ppc && my_arch=ppc
+ use ppc64 && my_arch=ppc64
+
+ # Skip the "build" target and use "all" instead to avoid the config
+ # sanity check (which would throw a fit about our compiler). There's
+ # a nice hack in the Makefile that overrides the value of CXX with
+ # COMPILER to support Travis CI and we abuse it to make sure that we
+ # build with our compiler of choice.
+ emake all ARCH="${my_arch}" \
+ COMP=$(tc-getCXX) \
+ COMPILER=$(tc-getCXX) \
+ debug=$(usex debug "yes" "no") \
+ optimize=$(usex optimize "yes" "no")
+}
+
+src_install() {
+ dobin "${PN}"
+ dodoc ../AUTHORS ../README.md
+}