summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-06-15 15:30:01 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-06-15 16:00:20 -0400
commitbdb15d3bba3fcbae4d5612931a9e9dc920172e3b (patch)
tree8b427a6f0464b09fcb1c93707f104477a655ca00 /games-board
parentgames-board/freedoko: tidy ebuild (diff)
downloadgentoo-bdb15d3bba3fcbae4d5612931a9e9dc920172e3b.tar.gz
gentoo-bdb15d3bba3fcbae4d5612931a9e9dc920172e3b.tar.bz2
gentoo-bdb15d3bba3fcbae4d5612931a9e9dc920172e3b.zip
games-board/pasang-emas: restrict tests, tidy
These tests aren't really meaningful and attempts to fetch .dtd just to validate a handful of .xml help files. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-board')
-rw-r--r--games-board/pasang-emas/pasang-emas-3.1.0-r1.ebuild44
1 files changed, 24 insertions, 20 deletions
diff --git a/games-board/pasang-emas/pasang-emas-3.1.0-r1.ebuild b/games-board/pasang-emas/pasang-emas-3.1.0-r1.ebuild
index 53bb194a1a53..5bf6199b8d6d 100644
--- a/games-board/pasang-emas/pasang-emas-3.1.0-r1.ebuild
+++ b/games-board/pasang-emas/pasang-emas-3.1.0-r1.ebuild
@@ -7,21 +7,27 @@ inherit gnome2-utils toolchain-funcs
DESCRIPTION="Traditional game of Brunei"
HOMEPAGE="http://pasang-emas.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
- extras? ( mirror://sourceforge/${PN}/pasang-emas-themes-1.0.tar.bz2
- mirror://sourceforge/${PN}/pet-marble.tar.bz2
- mirror://sourceforge/${PN}/pet-fragrance.tar.bz2 )"
+SRC_URI="
+ mirror://sourceforge/${PN}/${P}.tar.bz2
+ extras? (
+ mirror://sourceforge/${PN}/pasang-emas-themes-1.0.tar.bz2
+ mirror://sourceforge/${PN}/pet-marble.tar.bz2
+ mirror://sourceforge/${PN}/pet-fragrance.tar.bz2
+ )"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="extras nls"
+RESTRICT="test" # only used to validate .xml help files and fetches .dtd for it
-RDEPEND="app-text/gnome-doc-utils
- >=x11-libs/gtk+-2.18.2:2
- virtual/libintl"
+RDEPEND="
+ app-text/gnome-doc-utils
+ x11-libs/gtk+:2
+ nls? ( virtual/libintl )"
DEPEND="${RDEPEND}"
-BDEPEND="app-text/rarian
+BDEPEND="
+ app-text/rarian
nls? ( sys-devel/gettext )"
PATCHES=(
@@ -30,19 +36,19 @@ PATCHES=(
src_prepare() {
default
- sed -i \
- -e '/Encoding/d' \
- -e '/Icon/s:\.png::' \
- data/pasang-emas.desktop.in || die
+
+ sed -i '/Encoding/d;/Icon/s:\.png::' data/pasang-emas.desktop.in || die
+
gnome2_omf_fix
}
src_configure() {
- econf \
- --localedir="${EPREFIX}"/usr/share/locale \
- --with-omf-dir="${EPREFIX}"/usr/share/omf \
- --with-help-dir="${EPREFIX}"/usr/share/gnome/help \
+ local econfargs=(
$(use_enable nls)
+ --with-help-dir="${EPREFIX}"/usr/share/gnome/help
+ --with-omf-dir="${EPREFIX}"/usr/share/omf
+ )
+ econf "${econfargs[@]}"
}
src_compile(){
@@ -51,12 +57,10 @@ src_compile(){
src_install() {
default
+
if use extras; then
insinto /usr/share/${PN}/themes
- doins -r \
- "${WORKDIR}"/marble \
- "${WORKDIR}"/pasang-emas-themes-1.0/{conteng,kaca} \
- "${WORKDIR}"/fragrance
+ doins -r "${WORKDIR}"/{fragrance,marble,pasang-emas-themes-1.0/{conteng,kaca}}
fi
}