summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-04-05 00:28:26 +0200
committerDavid Seifert <soap@gentoo.org>2021-04-05 00:28:26 +0200
commitd197310dbae0e9b5a712b3bd77cf1af722a6ad1c (patch)
tree803f804069cf9e5573f00301c247701d034ccaa0 /games-board
parentapp-emulation/spice: add missing test restrict (diff)
downloadgentoo-d197310dbae0e9b5a712b3bd77cf1af722a6ad1c.tar.gz
gentoo-d197310dbae0e9b5a712b3bd77cf1af722a6ad1c.tar.bz2
gentoo-d197310dbae0e9b5a712b3bd77cf1af722a6ad1c.zip
games-board/blokish: Port to EAPI 7
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-board')
-rw-r--r--games-board/blokish/blokish-0.9.4-r3.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/games-board/blokish/blokish-0.9.4-r3.ebuild b/games-board/blokish/blokish-0.9.4-r3.ebuild
index a932e887ce6a..7316facb2a61 100644
--- a/games-board/blokish/blokish-0.9.4-r3.ebuild
+++ b/games-board/blokish/blokish-0.9.4-r3.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
WX_GTK_VER="3.0"
inherit autotools desktop wxwidgets
MY_P="${PN}_v${PV}"
+
DESCRIPTION="Open source clone of the four-player board game Blokus"
HOMEPAGE="https://sourceforge.net/projects/blokish/"
SRC_URI="mirror://sourceforge/blokish/${MY_P}.tgz"
@@ -16,11 +17,11 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-DEPEND="
+RDEPEND="
x11-libs/wxGTK:${WX_GTK_VER}[X,opengl]
virtual/glu
virtual/opengl"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${P}-gcc43.patch
@@ -44,9 +45,8 @@ src_prepare() {
src_install() {
default
+ dodoc -r docs/.
doicon src/${PN}.xpm
make_desktop_entry ${PN} Blokish ${PN}
-
- dodoc docs/*
}