summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2023-10-10 03:43:53 +0300
committerStefan Strogin <steils@gentoo.org>2023-10-10 00:54:52 +0000
commitdb417400c886b07681470089828ec6679a643730 (patch)
treef0850c0fb9d8dd54628387b4ee9e66145ec918bc /games-board
parentdev-qt/qtgui: use a safer fix for xkbcommon-1.6.0 (diff)
downloadgentoo-db417400c886b07681470089828ec6679a643730.tar.gz
gentoo-db417400c886b07681470089828ec6679a643730.tar.bz2
gentoo-db417400c886b07681470089828ec6679a643730.zip
games-board/pokerth: fix build with protobuf-23.3
Closes: https://bugs.gentoo.org/912793 Signed-off-by: Stefan Strogin <steils@gentoo.org>
Diffstat (limited to 'games-board')
-rw-r--r--games-board/pokerth/files/pokerth-1.1.2-protobuf-23.patch57
-rw-r--r--games-board/pokerth/pokerth-1.1.2-r1.ebuild1
2 files changed, 58 insertions, 0 deletions
diff --git a/games-board/pokerth/files/pokerth-1.1.2-protobuf-23.patch b/games-board/pokerth/files/pokerth-1.1.2-protobuf-23.patch
new file mode 100644
index 000000000000..4907b7541969
--- /dev/null
+++ b/games-board/pokerth/files/pokerth-1.1.2-protobuf-23.patch
@@ -0,0 +1,57 @@
+From da0855690cfec5129a60dfe33128ebd393389989 Mon Sep 17 00:00:00 2001
+From: Stefan Strogin <stefan@steils.org>
+Date: Tue, 10 Oct 2023 00:30:29 +0000
+Subject: [PATCH] Fix linking with protobuf 23
+
+---
+ chatcleaner.pro | 2 ++
+ pokerth_game.pro | 4 +++-
+ pokerth_server.pro | 4 +++-
+ 3 files changed, 8 insertions(+), 2 deletions(-)
+
+diff --git a/chatcleaner.pro b/chatcleaner.pro
+index 6d63b4a9..d9f50ab4 100644
+--- a/chatcleaner.pro
++++ b/chatcleaner.pro
+@@ -38,6 +38,8 @@ LIBPATH += lib
+ LIBS += -lpokerth_lib \
+ -lpokerth_protocol \
+ -lprotobuf \
++ -labsl_log_internal_check_op \
++ -labsl_log_internal_message \
+ -ltinyxml
+
+ win32 {
+diff --git a/pokerth_game.pro b/pokerth_game.pro
+index 2c188e44..9ef53666 100644
+--- a/pokerth_game.pro
++++ b/pokerth_game.pro
+@@ -524,7 +524,9 @@ unix:!mac {
+ kFreeBSD = $$find(UNAME, "kFreeBSD")
+ LIBS += -lsqlite3 \
+ -ltinyxml \
+- -lprotobuf
++ -lprotobuf \
++ -labsl_log_internal_check_op \
++ -labsl_log_internal_message
+ LIBS += $$BOOST_LIBS
+ LIBS += -lSDL \
+ -lSDL_mixer \
+diff --git a/pokerth_server.pro b/pokerth_server.pro
+index ccaff69e..20cc3eca 100644
+--- a/pokerth_server.pro
++++ b/pokerth_server.pro
+@@ -285,7 +285,9 @@ unix : !mac {
+ LIBS += $$BOOST_LIBS
+ LIBS += -lsqlite3 \
+ -ltinyxml \
+- -lprotobuf
++ -lprotobuf \
++ -labsl_log_internal_check_op \
++ -labsl_log_internal_message
+ LIBS += -lgsasl
+ !isEmpty( BSD ): isEmpty( kFreeBSD ){
+ LIBS += -lcrypto -liconv
+--
+2.42.0
+
diff --git a/games-board/pokerth/pokerth-1.1.2-r1.ebuild b/games-board/pokerth/pokerth-1.1.2-r1.ebuild
index 17063c8c8b00..76847f7d9fb7 100644
--- a/games-board/pokerth/pokerth-1.1.2-r1.ebuild
+++ b/games-board/pokerth/pokerth-1.1.2-r1.ebuild
@@ -46,6 +46,7 @@ PATCHES=(
# unbundle dev-cpp/websocketpp
"${FILESDIR}"/${PN}-1.1.2-system-websockets.patch
"${FILESDIR}"/${PN}-1.1.2-boost-1.73.patch
+ "${FILESDIR}"/${PN}-1.1.2-protobuf-23.patch
)
src_prepare() {