summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2023-02-25 14:17:07 -0800
committerSam James <sam@gentoo.org>2023-02-25 22:23:24 +0000
commitf084399b8a20ec5871f6ef116f975cc434762c54 (patch)
tree572b73947a79cd2b76bbc2f099eb7517a9d19268 /games-emulation/bsnes-jg/bsnes-jg-1.1.0.ebuild
parentgames-emulation/prosystem-jg: Add 1.5.2 + Remove 1.5.1 (diff)
downloadgentoo-f084399b8a20ec5871f6ef116f975cc434762c54.tar.gz
gentoo-f084399b8a20ec5871f6ef116f975cc434762c54.tar.bz2
gentoo-f084399b8a20ec5871f6ef116f975cc434762c54.zip
games-emulation/bsnes-jg: Add 1.1.1 + Remove 1.1.0
Bug fix release for an assert with -D_GLIBCXX_ASSERTIONS Bug: https://bugs.gentoo.org/896382 Signed-off-by: orbea <orbea@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/29791 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-emulation/bsnes-jg/bsnes-jg-1.1.0.ebuild')
-rw-r--r--games-emulation/bsnes-jg/bsnes-jg-1.1.0.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/games-emulation/bsnes-jg/bsnes-jg-1.1.0.ebuild b/games-emulation/bsnes-jg/bsnes-jg-1.1.0.ebuild
deleted file mode 100644
index 24d855263f55..000000000000
--- a/games-emulation/bsnes-jg/bsnes-jg-1.1.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs
-
-MY_PN=${PN%-*}
-MY_P=${MY_PN}-${PV}
-DESCRIPTION="Jolly Good Fork of bsnes"
-HOMEPAGE="https://gitlab.com/jgemu/bsnes"
-if [[ "${PV}" == *9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
-else
- SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
- S="${WORKDIR}/${MY_P}"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="ISC GPL-3+ LGPL-2.1+ MIT ZLIB"
-SLOT="1"
-
-DEPEND="
- media-libs/jg:1=
- media-libs/libsamplerate
-"
-RDEPEND="
- ${DEPEND}
- games-emulation/jgrf
-"
-BDEPEND="
- virtual/pkgconfig
-"
-
-src_compile() {
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
-}
-
-src_install() {
- emake install \
- DESTDIR="${D}" \
- PREFIX="${EPREFIX}"/usr \
- DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
- LIBDIR="${EPREFIX}/usr/$(get_libdir)"
-}