summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-11-20 20:52:57 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-11-20 23:55:31 -0500
commit1cdd5937af974cd53b9ee5b138031a310d5ab265 (patch)
tree3983b5430d75b042b870765c9fd2c5784c9cca01 /games-emulation/desmume
parentgames-arcade/grande-KXL: fix build w/ upcoming clang16 (diff)
downloadgentoo-1cdd5937af974cd53b9ee5b138031a310d5ab265.tar.gz
gentoo-1cdd5937af974cd53b9ee5b138031a310d5ab265.tar.bz2
gentoo-1cdd5937af974cd53b9ee5b138031a310d5ab265.zip
games-emulation/desmume: fix w/ clang16, filter-lto + -fno-strict
Looking a bit fragile for LTO overall, so haven't looked into doing proper fixes. Also GPL-2 -> GPL-2+ Closes: https://bugs.gentoo.org/858629 Closes: https://bugs.gentoo.org/874996 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation/desmume')
-rw-r--r--games-emulation/desmume/desmume-0.9.13-r1.ebuild (renamed from games-emulation/desmume/desmume-0.9.13.ebuild)9
1 files changed, 6 insertions, 3 deletions
diff --git a/games-emulation/desmume/desmume-0.9.13.ebuild b/games-emulation/desmume/desmume-0.9.13-r1.ebuild
index f4edfb4b5a3e..105f0464ab1c 100644
--- a/games-emulation/desmume/desmume-0.9.13.ebuild
+++ b/games-emulation/desmume/desmume-0.9.13-r1.ebuild
@@ -3,13 +3,13 @@
EAPI=8
-inherit meson xdg
+inherit flag-o-matic meson xdg
DESCRIPTION="Nintendo DS emulator"
HOMEPAGE="https://desmume.org/"
SRC_URI="https://github.com/TASEmulators/desmume/releases/download/release_$(ver_rs 1- _)/${P}.tar.xz"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="gdb +gui openal wifi"
@@ -42,8 +42,11 @@ PATCHES=(
DOCS=( ${PN}/{AUTHORS,ChangeLog,README,README.LIN,doc/.} )
src_configure() {
- local EMESON_SOURCE=${S}/${PN}/src/frontend/posix
+ append-flags -fno-strict-aliasing #858629
+ append-cppflags -D_XOPEN_SOURCE=500 #874996
+ filter-lto # odr issues
+ local EMESON_SOURCE=${S}/${PN}/src/frontend/posix
local emesonargs=(
$(meson_use gdb gdb-stub)
$(meson_use gui frontend-gtk)