summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-07-28 18:25:14 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2018-07-28 18:25:28 +0100
commit97a3987ca11005a9a5291d5f92f84edd4dfc88f1 (patch)
tree7253ef6773c221fdfb00c900e74479167b660a77 /games-emulation/dolphin/dolphin-5.0.ebuild
parentdev-python/pyenchant: bump to 2.0.0, supports enchant 2, Py3.7+PyPy3 (diff)
downloadgentoo-97a3987ca11005a9a5291d5f92f84edd4dfc88f1.tar.gz
gentoo-97a3987ca11005a9a5291d5f92f84edd4dfc88f1.tar.bz2
gentoo-97a3987ca11005a9a5291d5f92f84edd4dfc88f1.zip
games-emulation/dolphin: unconditionally disable llvm, bug #594940
llvm is used only for debug disassembly and is not detected by cmake scripts for various reasons. Let's sort llvm detection upstream first and restore downstream later. Reported-by: Michał Górny Closes: https://bugs.gentoo.org/594940 Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'games-emulation/dolphin/dolphin-5.0.ebuild')
-rw-r--r--games-emulation/dolphin/dolphin-5.0.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/games-emulation/dolphin/dolphin-5.0.ebuild b/games-emulation/dolphin/dolphin-5.0.ebuild
index 908b571cf426..491d92991bef 100644
--- a/games-emulation/dolphin/dolphin-5.0.ebuild
+++ b/games-emulation/dolphin/dolphin-5.0.ebuild
@@ -17,7 +17,9 @@ HOMEPAGE="https://www.dolphin-emu.org/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="alsa ao bluetooth doc egl +evdev ffmpeg libav llvm log lto openal +pch portaudio profile pulseaudio qt5 sdl upnp +wxwidgets"
+IUSE="alsa ao bluetooth doc egl +evdev ffmpeg libav log lto openal +pch portaudio profile pulseaudio qt5 sdl upnp +wxwidgets"
+
+RESTRICT=test
RDEPEND="
>=media-libs/libsfml-2.1
@@ -44,7 +46,6 @@ RDEPEND="
libav? ( media-video/libav:= )
!libav? ( media-video/ffmpeg:= )
)
- llvm? ( sys-devel/llvm:* )
openal? (
media-libs/openal
media-libs/libsoundtouch
@@ -89,9 +90,10 @@ src_prepare() {
if use !bluetooth; then
sed -i -e '/check_lib(BLUEZ/d' CMakeLists.txt || die
fi
- if use !llvm; then
- sed -i -e '/include(FindLLVM/d' CMakeLists.txt || die
- fi
+
+ # Unconditionally disable LLVM disassembler.
+ sed -i -e '/include(FindLLVM/d' CMakeLists.txt || die
+
if use !openal; then
sed -i -e '/include(FindOpenAL/d' CMakeLists.txt || die
fi