summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2022-10-20 23:35:43 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2022-10-20 23:35:43 +0200
commit20fa9f51828736eb5ca1293e587bfbb9f34ada80 (patch)
tree90f3cfe6b78e3e4b55ea8e5186c3f340e833c505 /games-emulation/dosbox-staging
parentmail-client/claws-mail: sync live ebuild (diff)
downloadgentoo-20fa9f51828736eb5ca1293e587bfbb9f34ada80.tar.gz
gentoo-20fa9f51828736eb5ca1293e587bfbb9f34ada80.tar.bz2
gentoo-20fa9f51828736eb5ca1293e587bfbb9f34ada80.zip
games-emulation/dosbox-staging: add 0.79.1
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'games-emulation/dosbox-staging')
-rw-r--r--games-emulation/dosbox-staging/Manifest1
-rw-r--r--games-emulation/dosbox-staging/dosbox-staging-0.79.1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/games-emulation/dosbox-staging/Manifest b/games-emulation/dosbox-staging/Manifest
index eabfa050e8e3..0996dcb1264d 100644
--- a/games-emulation/dosbox-staging/Manifest
+++ b/games-emulation/dosbox-staging/Manifest
@@ -1,2 +1,3 @@
DIST dosbox-staging-0.78.1.tar.gz 2968448 BLAKE2B 7b48763d10338d36e61696331358f7572a528c10d48e473dfaba6a8c96dd5d3ca2b9e1f5c595d653fbbe64f2b5f1d9f1ff8279dfab8f2cb49ac6faba697e97ca SHA512 3179e8eac00e22e35b36623c11688b8c60408bf487a56683269ff065988fbdf4319c16097232cc191695cf2e10c05f4c4eee15e92d9887ebf03a23f808d5db7c
DIST dosbox-staging-0.79.0.tar.gz 3114176 BLAKE2B 1206aed3d87ead0315a1e7e4ff814c4a787026521653b68532cb231590417c9124511ad8f39132d8d595b227675cfafdec4236a6f8dece43c139a401b7e9d11a SHA512 573365258d2fdc82ad8a803ce8f2b7f47b7219eeba9bc3253447ad48b9df793bc459947dbaa7a484bcce7e23ed3d0385438335dcdd2790c7eba6723960dfc890
+DIST dosbox-staging-0.79.1.tar.gz 3280884 BLAKE2B 48fd371df026392d59db2c9874f81b772b6595e2471a7ad1200e27e94fc87892f8e1c51288c1b0a430d8c3260535e35a00025047248551569f402b32a1ca3cf8 SHA512 6d7212229b58936cd1c4382f5e5cad45066e92f6a5b3bb2e97177ff7122dd527496a16dcefbfa84c3ad031d805c804c7872ec6eeaef9d695b0b8c4309f58acc7
diff --git a/games-emulation/dosbox-staging/dosbox-staging-0.79.1.ebuild b/games-emulation/dosbox-staging/dosbox-staging-0.79.1.ebuild
new file mode 100644
index 000000000000..0a3180cceb83
--- /dev/null
+++ b/games-emulation/dosbox-staging/dosbox-staging-0.79.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit meson xdg
+
+DESCRIPTION="Modernized DOSBox soft-fork"
+HOMEPAGE="https://dosbox-staging.github.io/"
+SRC_URI="https://github.com/dosbox-staging/dosbox-staging/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="+alsa debug dynrec +fluidsynth mt-32 network opengl slirp test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ debug? ( sys-libs/ncurses:0= )
+ fluidsynth? (
+ media-sound/fluid-soundfont
+ media-sound/fluidsynth
+ )
+ mt-32? ( media-libs/munt-mt32emu )
+ network? ( media-libs/sdl2-net )
+ opengl? ( virtual/opengl )
+ slirp? ( net-libs/libslirp )
+ media-libs/iir1
+ media-libs/libpng:0=
+ media-libs/libsdl2[joystick,opengl?,video,X]
+ media-libs/opusfile
+ media-libs/speexdsp
+ sys-libs/zlib
+ !games-emulation/dosbox"
+DEPEND="${RDEPEND}"
+BDEPEND="test? ( dev-cpp/gtest )"
+
+DOCS=( AUTHORS README THANKS )
+
+src_prepare() {
+ default
+
+ # We do not have default.sf2, use actual name from fluid-soundfont
+ sed -e "s/default.sf2/FluidR3_GM.sf2/" \
+ -i src/midi/midi_fluidsynth.cpp || die
+
+ # Disable license and docs install (handled by ebuild)
+ sed -e "/licenses_dir\|doc_dir/d" -i meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use alsa use_alsa)
+ $(meson_use debug)
+ -Ddynamic_core=$(usex dynrec dynrec dyn-x86)
+ $(meson_use fluidsynth use_fluidsynth)
+ $(meson_use mt-32 use_mt32emu)
+ $(meson_use network use_sdl2_net)
+ $(meson_use opengl use_opengl)
+ $(meson_use slirp use_slirp)
+ $(meson_feature test unit_tests)
+ )
+ meson_src_configure
+}