summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2021-12-29 12:05:43 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2021-12-29 12:16:43 +0100
commit899c36149c3c096840fecd4cbde55f588e6eb226 (patch)
treeb496ac4f5258f8fa99593e8178ef91ed513b0841 /games-emulation/dosbox-staging
parentapp-backup/rdiff-backup: drop old (diff)
downloadgentoo-899c36149c3c096840fecd4cbde55f588e6eb226.tar.gz
gentoo-899c36149c3c096840fecd4cbde55f588e6eb226.tar.bz2
gentoo-899c36149c3c096840fecd4cbde55f588e6eb226.zip
games-emulation/dosbox-staging: 0.78.0 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'games-emulation/dosbox-staging')
-rw-r--r--games-emulation/dosbox-staging/Manifest1
-rw-r--r--games-emulation/dosbox-staging/dosbox-staging-0.78.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/games-emulation/dosbox-staging/Manifest b/games-emulation/dosbox-staging/Manifest
index 0ef607994d30..fe6a745c58bb 100644
--- a/games-emulation/dosbox-staging/Manifest
+++ b/games-emulation/dosbox-staging/Manifest
@@ -1,3 +1,4 @@
DIST dosbox-staging-0.76.0.tar.gz 1908605 BLAKE2B 71b3c3d6a6444e2442d54b1db365ea66c9ee3db703be876facb8425355d82d817c080e005cefd103714e15fc7d1c17d6329c28d67bf74c143d0428e4f58e5142 SHA512 8c0357bcec08cac2cd2b306edd8b51ad05e16a3c3efb1f4c77e1d942f285493cae8aab45f1633e9c168c0b4b45aa289cf3ffc72685dc004d83127cdb6c76ae9d
DIST dosbox-staging-0.77.0.tar.gz 2579927 BLAKE2B 2a8381451ec110ca5350afc70c45f158329bd273b381ff61856ab721a0b194c7d501402453e9a36b90663ee8f6697dce8f64b05adf56efa8df2fd68161e420b6 SHA512 37259fecc091f1e318c2385d6e6fdc3b4ad0905ce63a7db1fc812c924bf8c01640692aca4f08b87d06e6001e50f3f2f4bb63c3715aa9cdfeebd205ed345558a0
DIST dosbox-staging-0.77.1.tar.gz 2622418 BLAKE2B c56020d263ceac199266a5c458c192441f836ea2e71e1564da175b7ae522286ca1b6a07062498ccea795bbf330beecb5ef99a0130637b1df26603315d48ea6ff SHA512 fe5d6150a88f5c276aee5672f98c15b5ffee702fe9934919d3e78068efd1a85f08a8f04352bc6a8fe850324e33f3227340c59242db6cbae0475b12a58b749cac
+DIST dosbox-staging-0.78.0.tar.gz 2908118 BLAKE2B 77dd6afd7c8f62e2936c2ed1545faf1f2700b7bceba4afd6f77eff6b2bd1ea7b7693e3975d38098774f4f6076099251e7aa53cd20a5dec7daefb34a3533fdf40 SHA512 e56b4735f1a741f2c160646f205776e2407ab3333d4d13ce918ff447a08817862a32167afa47b3c7e35bc942bc06aea7d14e25bfe64fce9ee88a843488733746
diff --git a/games-emulation/dosbox-staging/dosbox-staging-0.78.0.ebuild b/games-emulation/dosbox-staging/dosbox-staging-0.78.0.ebuild
new file mode 100644
index 000000000000..652dbe698a9a
--- /dev/null
+++ b/games-emulation/dosbox-staging/dosbox-staging-0.78.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit meson xdg
+
+DESCRIPTION="Modernized DOSBox soft-fork"
+HOMEPAGE="https://dosbox-staging.github.io/"
+SRC_URI="https://github.com/dosbox-staging/dosbox-staging/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="+alsa debug dynrec +fluidsynth mt-32 network opengl test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ debug? ( sys-libs/ncurses:0= )
+ fluidsynth? (
+ media-sound/fluid-soundfont
+ media-sound/fluidsynth
+ )
+ mt-32? ( media-libs/munt-mt32emu )
+ network? ( media-libs/sdl2-net )
+ opengl? ( virtual/opengl )
+ media-libs/libpng:0=
+ media-libs/libsdl2[joystick,opengl?,video,X]
+ media-libs/opusfile
+ sys-libs/zlib
+ !games-emulation/dosbox"
+DEPEND="${RDEPEND}"
+BDEPEND="test? ( dev-cpp/gtest )"
+
+DOCS=( AUTHORS README THANKS )
+
+src_prepare() {
+ default
+
+ # We do not have default.sf2, use actual name from fluid-soundfont
+ sed -e "s/default.sf2/FluidR3_GM.sf2/" \
+ -i src/midi/midi_fluidsynth.cpp || die
+
+ # Disable license and docs install (handled by ebuild)
+ sed -e "/licenses_dir\|doc_dir/d" -i meson.build || die
+
+ # Test failing on some platforms, bug #817908
+ # https://github.com/dosbox-staging/dosbox-staging/issues/1230
+ sed -i 's/.*soft_limit.*//' tests/meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use alsa use_alsa)
+ $(meson_use debug)
+ -Ddynamic_core=$(usex dynrec dynrec dyn-x86)
+ $(meson_use fluidsynth use_fluidsynth)
+ $(meson_use mt-32 use_mt32emu)
+ $(meson_use network use_sdl2_net)
+ $(meson_use opengl use_opengl)
+ $(meson_feature test unit_tests)
+ )
+ meson_src_configure
+}