summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-06-25 20:57:15 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-06-25 21:35:06 -0400
commit0e464bdb6f179404619bd3265c31acf1e7a06a50 (patch)
tree3d6d78256a99090210bdad3331f371cd47c4fc67 /games-emulation/fceux
parentdev-perl/Log-Any: Keyword 1.709.0 arm64, #797652 (diff)
downloadgentoo-0e464bdb6f179404619bd3265c31acf1e7a06a50.tar.gz
gentoo-0e464bdb6f179404619bd3265c31acf1e7a06a50.tar.bz2
gentoo-0e464bdb6f179404619bd3265c31acf1e7a06a50.zip
games-emulation/fceux: add 2.4.0
New patches are just conversion of the sed commands. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation/fceux')
-rw-r--r--games-emulation/fceux/Manifest1
-rw-r--r--games-emulation/fceux/fceux-2.4.0.ebuild48
-rw-r--r--games-emulation/fceux/files/fceux-2.4.0-desktop.patch18
-rw-r--r--games-emulation/fceux/files/fceux-2.4.0-no-git.patch12
4 files changed, 79 insertions, 0 deletions
diff --git a/games-emulation/fceux/Manifest b/games-emulation/fceux/Manifest
index 61c17d5f22cd..a3f578e4ec49 100644
--- a/games-emulation/fceux/Manifest
+++ b/games-emulation/fceux/Manifest
@@ -1 +1,2 @@
DIST fceux-2.3.0.src.tar.gz 20779030 BLAKE2B 0d9a0e1f326bdcde4e360a03755c9d807a59e3f3826017e2923527f3ec214bec4c9737f98a8abc4e4971098d127ce8e95eb4142fa8d0bd71109190e6d2c93861 SHA512 46b53f0c4c790ae4f7d5e800adf81cce3c7ccf4b06f972d46e29c0170485e291516709a8c28b26c762d535453e280a6c6de935869c7674bb135c3dca2e266407
+DIST fceux-2.4.0.tar.gz 21807471 BLAKE2B 5b4d5e9438cfc974cb5ed1838b0845a1d125366fcfbe4ad72c1a5da7caed7bb763a7c66933933f61223abb9dc4c25f0ac7875a0751d122bf75e8567ca5de6cc4 SHA512 3f53db1091e28c91bff90a2d6c77bd3c022a7c20a29b07e6cb88e9ae4795ce7f9e68d15ac0f90721472f8c262907a2564e0be7adc8df2eb3ef252215717f30a0
diff --git a/games-emulation/fceux/fceux-2.4.0.ebuild b/games-emulation/fceux/fceux-2.4.0.ebuild
new file mode 100644
index 000000000000..b82b752cf01d
--- /dev/null
+++ b/games-emulation/fceux/fceux-2.4.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-1 )
+
+inherit xdg cmake lua-single
+
+DESCRIPTION="Portable Famicom/NES emulator, an evolution of the original FCE Ultra"
+HOMEPAGE="https://fceux.com/"
+SRC_URI="mirror://sourceforge/fceultra/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+# TODO: QT6 support (disabled by default) when available in Gentoo
+RDEPEND="
+ ${LUA_DEPS}
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5[-gles2-only]
+ dev-qt/qtwidgets:5
+ media-libs/libglvnd
+ media-libs/libsdl2[joystick,sound,threads,video]
+ media-libs/x264:=
+ sys-libs/zlib:=[minizip]"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2.2-warnings.patch
+ "${FILESDIR}"/${P}-desktop.patch
+ "${FILESDIR}"/${P}-no-git.patch
+)
+
+DOCS=( README TODO-SDL changelog.txt documentation/. readme.md )
+
+src_install() {
+ cmake_src_install
+
+ # remove unused/duplicate files
+ rm "${ED}"/usr/share/fceux/{lua5{1,.1}.dll,{fceux,taseditor}.chm} \
+ "${ED}"/usr/share/doc/${PF}/fceux{,-net-server}.6 \
+ "${ED}"/usr/share/man/man6/fceux-net-server.6 || die
+}
diff --git a/games-emulation/fceux/files/fceux-2.4.0-desktop.patch b/games-emulation/fceux/files/fceux-2.4.0-desktop.patch
new file mode 100644
index 000000000000..0abf6f9a64c8
--- /dev/null
+++ b/games-emulation/fceux/files/fceux-2.4.0-desktop.patch
@@ -0,0 +1,18 @@
+Remove harcoded paths from .desktop, not replacing with
+make_desktop_entry given upstream's also defines MimeType.
+--- a/fceux.desktop
++++ b/fceux.desktop
+@@ -7,4 +7,4 @@
+ Comment=Emulate NES ROMs
+-Exec=/usr/bin/fceux %f
+-Icon=/usr/share/pixmaps/fceux1.png
++Exec=fceux %f
++Icon=fceux1
+ Terminal=false
+@@ -17,3 +17,2 @@
+ Exec=fceux -f 1
+-OnlyShowIn=Unity
+ [Desktop Action DefaultConfig]
+@@ -21,2 +20 @@
+ Exec=fceux --no-config 1
+-OnlyShowIn=Unity
diff --git a/games-emulation/fceux/files/fceux-2.4.0-no-git.patch b/games-emulation/fceux/files/fceux-2.4.0-no-git.patch
new file mode 100644
index 000000000000..fe9a7d35b46b
--- /dev/null
+++ b/games-emulation/fceux/files/fceux-2.4.0-no-git.patch
@@ -0,0 +1,12 @@
+Prevent meaningless use of git (QA notice if missing) in a release.
+--- a/scripts/genGitHdr.sh
++++ b/scripts/genGitHdr.sh
+@@ -8,6 +8,6 @@
+ echo "Output File: $OUTPUT_DIR/$FILE";
+
+-GIT_URL=`git config --get remote.origin.url`;
+-GIT_REV=`git rev-parse HEAD`;
++GIT_URL=
++GIT_REV=
+
+ echo "// fceux_git_info.cpp -- DO NOT EDIT: This file is auto-generated at build" >| $TMP_FILE;