summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-29 11:38:18 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-29 13:25:37 +0200
commit9f88f5db5b127935744d3f310f6e1023f3439c69 (patch)
tree5b0041382cac4cac04cb5c7960ea587cc430be17 /games-emulation/gcube/gcube-0.4-r2.ebuild
parentgames-emulation/gambatte: Drop old (diff)
downloadgentoo-9f88f5db5b127935744d3f310f6e1023f3439c69.tar.gz
gentoo-9f88f5db5b127935744d3f310f6e1023f3439c69.tar.bz2
gentoo-9f88f5db5b127935744d3f310f6e1023f3439c69.zip
games-emulation/gcube: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-emulation/gcube/gcube-0.4-r2.ebuild')
-rw-r--r--games-emulation/gcube/gcube-0.4-r2.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/games-emulation/gcube/gcube-0.4-r2.ebuild b/games-emulation/gcube/gcube-0.4-r2.ebuild
new file mode 100644
index 000000000000..6194fc6a2103
--- /dev/null
+++ b/games-emulation/gcube/gcube-0.4-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit flag-o-matic
+
+DESCRIPTION="Gamecube emulator"
+HOMEPAGE="http://gcube.exemu.net/"
+SRC_URI="http://gcube.exemu.net/downloads/${P}-src.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ virtual/opengl
+ media-libs/libsdl[joystick,opengl,sound,video]
+ virtual/jpeg:0
+ sys-libs/ncurses:0=
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PV}"
+
+src_prepare() {
+ default
+
+ sed -i -e '/^CFLAGS=-g/d' Makefile.rules || die
+
+ eapply "${FILESDIR}"/${P}-ldflags.patch \
+ "${FILESDIR}"/${P}-underlink.patch \
+ "${FILESDIR}"/${P}-gcc47.patch
+
+ sed -i -e '/^CC=/d' Makefile || die
+
+ append-cflags -std=gnu89 # build with gcc5 (bug #570504)
+}
+
+src_install() {
+ local x
+
+ dobin gcmap gcube
+ for x in bin2dol isopack thpview tplx ; do
+ newbin ${x} ${PN}-${x}
+ done
+
+ einstalldocs
+}