summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2023-08-07 14:21:17 -0700
committerSam James <sam@gentoo.org>2023-08-29 07:08:14 +0100
commite9253da60015c8bbd2e995d9d886f93d24d298ac (patch)
treec76968b934d5afdbebae5e6d3fa361bd08715d26 /games-emulation/geolith-jg
parentmail-client/alpine: workarounds for strict prototypes & make --shuffle (diff)
downloadgentoo-e9253da60015c8bbd2e995d9d886f93d24d298ac.tar.gz
gentoo-e9253da60015c8bbd2e995d9d886f93d24d298ac.tar.bz2
gentoo-e9253da60015c8bbd2e995d9d886f93d24d298ac.zip
games-emulation/geolith-jg: new package, add 0.1.0, 9999
Closes: https://bugs.gentoo.org/912234 Signed-off-by: orbea <orbea@riseup.net> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-emulation/geolith-jg')
-rw-r--r--games-emulation/geolith-jg/Manifest1
-rw-r--r--games-emulation/geolith-jg/geolith-jg-0.1.0.ebuild51
-rw-r--r--games-emulation/geolith-jg/geolith-jg-9999.ebuild51
-rw-r--r--games-emulation/geolith-jg/metadata.xml23
4 files changed, 126 insertions, 0 deletions
diff --git a/games-emulation/geolith-jg/Manifest b/games-emulation/geolith-jg/Manifest
new file mode 100644
index 000000000000..6def4d891bdb
--- /dev/null
+++ b/games-emulation/geolith-jg/Manifest
@@ -0,0 +1 @@
+DIST geolith-0.1.0.tar.bz2 245785 BLAKE2B a1a541bdf32da722a095282b4b0f41f6c4d27c9450615842c99a080a61d60c189b0a769812704d30ff0d20ccfbf5c950f01131bed7694dbd5e5814b73390c272 SHA512 94112de9e6f33593365559f275f3d2bcf759346c706c1608e010d60987c4e2337b50dce980a144c25593fe4a0bc4880d9bd955355f2ceed710ab39afcad4e916
diff --git a/games-emulation/geolith-jg/geolith-jg-0.1.0.ebuild b/games-emulation/geolith-jg/geolith-jg-0.1.0.ebuild
new file mode 100644
index 000000000000..df45d534adcc
--- /dev/null
+++ b/games-emulation/geolith-jg/geolith-jg-0.1.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good Neo Geo AES/MVS Emulator"
+HOMEPAGE="https://gitlab.com/jgemu/geolith"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD MIT"
+SLOT="1"
+
+DEPEND="
+ dev-libs/miniz
+ media-libs/jg:1=
+ media-libs/speexdsp
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/jgrf
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)" \
+ USE_EXTERNAL_MINIZ=1
+}
+
+src_install() {
+ emake install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ USE_EXTERNAL_MINIZ=1
+}
diff --git a/games-emulation/geolith-jg/geolith-jg-9999.ebuild b/games-emulation/geolith-jg/geolith-jg-9999.ebuild
new file mode 100644
index 000000000000..df45d534adcc
--- /dev/null
+++ b/games-emulation/geolith-jg/geolith-jg-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good Neo Geo AES/MVS Emulator"
+HOMEPAGE="https://gitlab.com/jgemu/geolith"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD MIT"
+SLOT="1"
+
+DEPEND="
+ dev-libs/miniz
+ media-libs/jg:1=
+ media-libs/speexdsp
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/jgrf
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)" \
+ USE_EXTERNAL_MINIZ=1
+}
+
+src_install() {
+ emake install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ USE_EXTERNAL_MINIZ=1
+}
diff --git a/games-emulation/geolith-jg/metadata.xml b/games-emulation/geolith-jg/metadata.xml
new file mode 100644
index 000000000000..8ba92a8ef70b
--- /dev/null
+++ b/games-emulation/geolith-jg/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>orbea@riseup.net</email>
+ <name>orbea</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ Geolith is a highly accurate emulator for the Neo Geo AES and MVS.
+ This project began life as a fork of GnGEO 0.8.1. All original
+ components were removed or replaced as the project progressed, with
+ the resulting codebase being entirely new, with all new code written
+ under the BSD 3-Clause license.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://gitlab.com/jgemu/geolith/-/issues</bugs-to>
+ <remote-id type="gitlab">jgemu/geolith</remote-id>
+ </upstream>
+</pkgmetadata>