summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-06-01 07:59:26 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-06-01 22:20:51 -0400
commitf161975e2a310eec02789128306f8bfb54af35a8 (patch)
treefe16b69e4ef5197eada228919b39b40e587a4581 /games-emulation/hatari/files
parentgames-emulation/emutos: mark ALLARCHES (diff)
downloadgentoo-f161975e2a310eec02789128306f8bfb54af35a8.tar.gz
gentoo-f161975e2a310eec02789128306f8bfb54af35a8.tar.bz2
gentoo-f161975e2a310eec02789128306f8bfb54af35a8.zip
games-emulation/hatari: add 2.3.1
- removed upstreamed joystick patch - replaced default-rom patch by using /etc/hatari.cfg, effective even if user has their own .cfg in $HOME unless overrides same option - removed libsdl1 support, upstream advises against using and it'll be removed entirely next version - added python3_10 (haven't managed to find issues) - the python-ui frontend was previously missing gtk+:3[introspection] dep and, rather than add unconditionally, introducing USE=gui - plus other small adjustments/fixes bug 739146 config-file test failure was caused by the default-rom patch Closes: https://bugs.gentoo.org/739146 Closes: https://bugs.gentoo.org/765004 Closes: https://bugs.gentoo.org/765115 Closes: https://github.com/gentoo/gentoo/pull/20905 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation/hatari/files')
-rw-r--r--games-emulation/hatari/files/hatari-2.3.1-caps5-include-path.patch18
-rw-r--r--games-emulation/hatari/files/hatari-2.3.1-cmake-include-checksym.patch12
2 files changed, 30 insertions, 0 deletions
diff --git a/games-emulation/hatari/files/hatari-2.3.1-caps5-include-path.patch b/games-emulation/hatari/files/hatari-2.3.1-caps5-include-path.patch
new file mode 100644
index 000000000000..a12207b09583
--- /dev/null
+++ b/games-emulation/hatari/files/hatari-2.3.1-caps5-include-path.patch
@@ -0,0 +1,18 @@
+Gentoo's spsdeclib ebuild installs headers in caps5/
+while upstream now expects them in caps/
+
+See: https://github.com/hatari/hatari/commit/367a87b
+--- a/cmake/FindCapsImage.cmake
++++ b/cmake/FindCapsImage.cmake
+@@ -6,3 +6,3 @@
+
+-SET(CAPSIMAGE_DIR caps)
++SET(CAPSIMAGE_DIR caps5)
+ FIND_PATH(CAPSIMAGE_INCLUDE_DIR ${CAPSIMAGE_DIR}/CapsAPI.h)
+--- a/src/floppy_ipf.c
++++ b/src/floppy_ipf.c
+@@ -34,3 +34,3 @@
+ #endif
+-#include <caps/CapsLibAll.h>
++#include <caps5/CapsLibAll.h>
+ #define CapsLong SDWORD
diff --git a/games-emulation/hatari/files/hatari-2.3.1-cmake-include-checksym.patch b/games-emulation/hatari/files/hatari-2.3.1-cmake-include-checksym.patch
new file mode 100644
index 000000000000..39da11ea307d
--- /dev/null
+++ b/games-emulation/hatari/files/hatari-2.3.1-cmake-include-checksym.patch
@@ -0,0 +1,12 @@
+Fix edge case build failure triggered by passing every
+DISABLE_FIND_PACKAGE, including disabling the normally
+always-enabled readline.
+
+CMake Error at CMakeLists.txt:229 (check_symbol_exists):
+ Unknown CMake command "check_symbol_exists".
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -12,2 +12,3 @@
+ include(CheckStructHasMember)
++include(CheckSymbolExists)
+ include(CheckCCompilerFlag)