summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2022-12-27 17:15:19 -0800
committerSam James <sam@gentoo.org>2023-01-15 14:16:12 +0000
commitdfe122017d9a697df6b72e58fbd3b077f1bdd778 (patch)
tree8c399e9109613f9a817f06034075d11bebeaee5c /games-emulation/jollycv-jg
parentgames-emulation/gambatte-jg: New package, v0.5.1 (diff)
downloadgentoo-dfe122017d9a697df6b72e58fbd3b077f1bdd778.tar.gz
gentoo-dfe122017d9a697df6b72e58fbd3b077f1bdd778.tar.bz2
gentoo-dfe122017d9a697df6b72e58fbd3b077f1bdd778.zip
games-emulation/jollycv-jg: New package, v1.0.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-emulation/jollycv-jg')
-rw-r--r--games-emulation/jollycv-jg/Manifest1
-rw-r--r--games-emulation/jollycv-jg/jollycv-jg-1.0.1.ebuild46
-rw-r--r--games-emulation/jollycv-jg/jollycv-jg-9999.ebuild46
-rw-r--r--games-emulation/jollycv-jg/metadata.xml21
4 files changed, 114 insertions, 0 deletions
diff --git a/games-emulation/jollycv-jg/Manifest b/games-emulation/jollycv-jg/Manifest
new file mode 100644
index 000000000000..db74f59137b3
--- /dev/null
+++ b/games-emulation/jollycv-jg/Manifest
@@ -0,0 +1 @@
+DIST jollycv-1.0.1.tar.bz2 58785 BLAKE2B 1d9897ac7ad8eff10d27f72b0b4d2036266fdcefd208266dab7ae52815b952f35a997b78b53c8c4aa7ba88abee969badec4cefd4c4c0dbfba2114e2f287ce6e5 SHA512 e52866dc70ccdc9829a055158078ddc842adde11fd42b1f06b1af278d7a9edf5c950a4f2297cc47acdac0ad85174c8b8b219ab9c411754d5eec7c190456ef9ef
diff --git a/games-emulation/jollycv-jg/jollycv-jg-1.0.1.ebuild b/games-emulation/jollycv-jg/jollycv-jg-1.0.1.ebuild
new file mode 100644
index 000000000000..5e053a30bdb2
--- /dev/null
+++ b/games-emulation/jollycv-jg/jollycv-jg-1.0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good ColecoVision Emulator"
+HOMEPAGE="https://gitlab.com/jgemu/jollycv"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD MIT"
+SLOT="1"
+
+DEPEND="
+ media-libs/jg:1=
+ media-libs/speexdsp
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/jgrf
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}
diff --git a/games-emulation/jollycv-jg/jollycv-jg-9999.ebuild b/games-emulation/jollycv-jg/jollycv-jg-9999.ebuild
new file mode 100644
index 000000000000..5e053a30bdb2
--- /dev/null
+++ b/games-emulation/jollycv-jg/jollycv-jg-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good ColecoVision Emulator"
+HOMEPAGE="https://gitlab.com/jgemu/jollycv"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD MIT"
+SLOT="1"
+
+DEPEND="
+ media-libs/jg:1=
+ media-libs/speexdsp
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/jgrf
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}
diff --git a/games-emulation/jollycv-jg/metadata.xml b/games-emulation/jollycv-jg/metadata.xml
new file mode 100644
index 000000000000..4a63854c7f92
--- /dev/null
+++ b/games-emulation/jollycv-jg/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>orbea@riseup.net</email>
+ <name>orbea</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ JollyCV is a highly accurate emulator for the ColecoVision,
+ including support for the Super Game Module. It was written in
+ standards compliant ISO C11 specifically for The Jolly Good API.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://gitlab.com/jgemu/jollycv/-/issues</bugs-to>
+ <remote-id type="gitlab">jgemu/jollycv</remote-id>
+ </upstream>
+</pkgmetadata>