summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-emulation/kigb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-emulation/kigb')
-rw-r--r--games-emulation/kigb/Manifest1
-rw-r--r--games-emulation/kigb/files/kigb16
-rw-r--r--games-emulation/kigb/kigb-2.02.ebuild41
-rw-r--r--games-emulation/kigb/metadata.xml5
4 files changed, 63 insertions, 0 deletions
diff --git a/games-emulation/kigb/Manifest b/games-emulation/kigb/Manifest
new file mode 100644
index 000000000000..7c69ac762927
--- /dev/null
+++ b/games-emulation/kigb/Manifest
@@ -0,0 +1 @@
+DIST kigb_lin.tar.gz 477324 SHA256 71adb8018ba80b80b7aa454161d47ec447e74c4797ba752b130d46e79ffcf3b3 SHA512 ca8b10cc05884c92157dde2b034c7e95f28ed7eed771d0383265f942f0cacea791284516b551e96ba07a035068a7039c8faa19ec417ee117b6a350692bbff01d WHIRLPOOL 1772c689e28bd7a6095737b7327867624fe381a452fbf8ec984e8becdb06da37aa914cecf45c2ee3059db8a9563f445c33f8b3f30854304fed6e20c3c42a9f01
diff --git a/games-emulation/kigb/files/kigb b/games-emulation/kigb/files/kigb
new file mode 100644
index 000000000000..7a3e691b7f31
--- /dev/null
+++ b/games-emulation/kigb/files/kigb
@@ -0,0 +1,16 @@
+#!/bin/bash
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+kigb_dir="${HOME}/.kigb"
+
+if [[ ! -d "${kigb_dir}" ]] ; then
+ mkdir -p "${kigb_dir}"
+ cd "${kigb_dir}"
+ mkdir cfg inp rom save snap state
+ ln -s GENTOODIR/kigb/kigb kigb
+fi
+
+cd "${kigb_dir}"
+exec ./kigb "$@"
diff --git a/games-emulation/kigb/kigb-2.02.ebuild b/games-emulation/kigb/kigb-2.02.ebuild
new file mode 100644
index 000000000000..9eef5dbb6f01
--- /dev/null
+++ b/games-emulation/kigb/kigb-2.02.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit games
+
+DESCRIPTION="A Gameboy (GB, SGB, GBA) Emulator for Linux"
+HOMEPAGE="http://kigb.emuunlim.com/"
+SRC_URI="http://kigb.emuunlim.com/${PN}_lin.tar.gz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* x86"
+IUSE=""
+RESTRICT="mirror bindist strip"
+
+RDEPEND="x11-libs/libXext
+ sys-libs/zlib
+ dev-games/hawknl
+ =virtual/libstdc++-3*"
+
+S=${WORKDIR}
+
+src_prepare() {
+ # use the system version
+ rm -f libNL.so*
+ # wrapper script creates these in the users' home directories.
+ rm -rf cfg inp snap state rom save
+ cp "${FILESDIR}/kigb" "${T}/" || die
+ sed -i \
+ -e "s:GENTOODIR:${GAMES_PREFIX_OPT}:" "${T}/kigb" || die
+}
+
+src_install() {
+ dogamesbin "${T}/kigb"
+ exeinto "${GAMES_PREFIX_OPT}/${PN}"
+ doexe kigb
+ dodoc doc/*
+ prepgamesdirs
+}
diff --git a/games-emulation/kigb/metadata.xml b/games-emulation/kigb/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-emulation/kigb/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>