summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-06-15 17:32:10 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-06-15 17:33:33 -0400
commit1ca9cc16cc005f0933cc75f7bf7a50e8f3141cd2 (patch)
tree56b20dc13d945418414e70f968f07d75e1bbb207 /games-emulation/mednafen/mednafen-1.27.1.ebuild
parentdev-python/humanize: Bump to 3.9.0 (diff)
downloadgentoo-1ca9cc16cc005f0933cc75f7bf7a50e8f3141cd2.tar.gz
gentoo-1ca9cc16cc005f0933cc75f7bf7a50e8f3141cd2.tar.bz2
gentoo-1ca9cc16cc005f0933cc75f7bf7a50e8f3141cd2.zip
games-emulation/mednafen: add 1.27.1
Removes support for libsndfile and adds flac in its place. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation/mednafen/mednafen-1.27.1.ebuild')
-rw-r--r--games-emulation/mednafen/mednafen-1.27.1.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/games-emulation/mednafen/mednafen-1.27.1.ebuild b/games-emulation/mednafen/mednafen-1.27.1.ebuild
new file mode 100644
index 000000000000..ff0f36561a36
--- /dev/null
+++ b/games-emulation/mednafen/mednafen-1.27.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic pax-utils toolchain-funcs
+
+DESCRIPTION="Argument-driven multi-system emulator utilizing OpenGL and SDL"
+HOMEPAGE="https://mednafen.github.io/"
+SRC_URI="https://mednafen.github.io/releases/files/${P}.tar.xz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa cpu_flags_ppc_altivec flac jack"
+
+RDEPEND="
+ dev-libs/lzo:2
+ dev-libs/trio
+ media-libs/libsdl2[joystick,opengl,video]
+ media-libs/tremor
+ media-sound/musepack-tools
+ sys-libs/zlib:=[minizip]
+ virtual/libintl
+ alsa? ( media-libs/alsa-lib )
+ flac? ( media-libs/flac )
+ jack? ( virtual/jack )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # don't let the build system mess with CFLAGS more than necessary,
+ # most are questionable (see README.PORTING/configure.ac comments)
+ # -fwrapv: kept for bug #539992
+ sed -e '/CC_OPT.*CODEGEN_FLAGS/{/-fwrapv/!d}' \
+ -e '/CC_OPT.*NO_STACK_PROTECTOR_FLAGS/d' \
+ -e '/CC_OPT.*OPTIMIZER_FLAGS/c\:' \
+ -e '/CC_OPT.*-mtune.*SS_EXTRA_FLAGS/d' \
+ -i configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ # disable unnecessary warnings not to confuse users (see src/types.h)
+ append-cppflags -DMDFN_DISABLE_{NO_OPT,PICPIE}_ERRWARN
+
+ local myeconfargs=(
+ $(use_enable alsa)
+ $(use_enable cpu_flags_ppc_altivec altivec)
+ $(use_enable jack)
+ $(use_with flac libflac)
+ --with-external-{lzo,mpcdec,tremor,trio}
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ local DOCS=(
+ ChangeLog
+ Documentation/{cheats.txt,fname_format.txt,modules.def,settings.def}
+ )
+ local HTML_DOCS=( Documentation/*.{css,html,png} )
+
+ default
+
+ pax-mark m "${ED}"/usr/bin/mednafen
+}