summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-01-01 20:50:31 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-01-01 21:29:38 +0100
commit23da15cf6d34199d69e3c9e1d52042116f613e5c (patch)
treef988e306fb7ef2f3eaede496986c8cd08f3d1d17 /games-emulation/melonds/melonds-9999.ebuild
parentdev-python/ytmusicapi: bump to 1.4.0 (diff)
downloadgentoo-23da15cf6d34199d69e3c9e1d52042116f613e5c.tar.gz
gentoo-23da15cf6d34199d69e3c9e1d52042116f613e5c.tar.bz2
gentoo-23da15cf6d34199d69e3c9e1d52042116f613e5c.zip
games-emulation/melonds: update doc
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'games-emulation/melonds/melonds-9999.ebuild')
-rw-r--r--games-emulation/melonds/melonds-9999.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/games-emulation/melonds/melonds-9999.ebuild b/games-emulation/melonds/melonds-9999.ebuild
index 9255b44e2e4f..ff839958a635 100644
--- a/games-emulation/melonds/melonds-9999.ebuild
+++ b/games-emulation/melonds/melonds-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019-2023 Gentoo Authors
+# Copyright 2019-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -12,13 +12,15 @@ DESCRIPTION="Nintendo DS emulator, sorta"
HOMEPAGE="http://melonds.kuribo64.net
https://github.com/Arisotura/melonDS"
-if [[ ${PV} == *9999* ]] ; then
+if [[ "${PV}" == *9999* ]] ; then
inherit git-r3
+
EGIT_REPO_URI="https://github.com/Arisotura/${MY_PN}.git"
else
SRC_URI="https://github.com/Arisotura/${MY_PN}/archive/${PV}.tar.gz
-> ${MY_P}.tar.gz"
- S="${WORKDIR}"/${MY_P}
+ S="${WORKDIR}/${MY_P}"
+
KEYWORDS="~amd64"
fi
@@ -51,7 +53,7 @@ DOC_CONTENTS="You need the following files in order to run melonDS:
- firmware.bin
- romlist.bin
Place them in ~/.config/melonDS
-Those files can be found somewhere on the Internet ;-)"
+Those files can be extracted from devices or found somewhere on the Internet ;-)"
src_prepare() {
filter-lto
@@ -61,7 +63,7 @@ src_prepare() {
}
src_configure() {
- local mycmakeargs=(
+ local -a mycmakeargs=(
-DBUILD_SHARED_LIBS=OFF
-DENABLE_JIT=$(usex jit)
-DENABLE_OGLRENDERER=$(usex opengl)