summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authordakrk <dark@darkok.xyz>2023-04-05 02:59:11 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-04-05 04:40:23 +0200
commitbdec9ff75969207c31ce201a5dbc709fd1fe7a8a (patch)
tree7051785a1b626663d778dad57bf8667dd695a30a /games-emulation/melonds/melonds-9999.ebuild
parentgames-emulation/melonds: Drop media-libs/libepoxy dependency (diff)
downloadgentoo-bdec9ff75969207c31ce201a5dbc709fd1fe7a8a.tar.gz
gentoo-bdec9ff75969207c31ce201a5dbc709fd1fe7a8a.tar.bz2
gentoo-bdec9ff75969207c31ce201a5dbc709fd1fe7a8a.zip
games-emulation/melonds: add wayland USE flag
Signed-off-by: dakrk <dark@darkok.xyz> Closes: https://github.com/gentoo/gentoo/pull/30481 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'games-emulation/melonds/melonds-9999.ebuild')
-rw-r--r--games-emulation/melonds/melonds-9999.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/games-emulation/melonds/melonds-9999.ebuild b/games-emulation/melonds/melonds-9999.ebuild
index d68ba29eb6b8..3bf0d22f5d0e 100644
--- a/games-emulation/melonds/melonds-9999.ebuild
+++ b/games-emulation/melonds/melonds-9999.ebuild
@@ -22,13 +22,12 @@ else
KEYWORDS="~amd64"
fi
-IUSE="+jit +opengl"
+IUSE="+jit +opengl wayland"
LICENSE="BSD-2 GPL-2 GPL-3 Unlicense"
SLOT="0"
RDEPEND="
app-arch/libarchive
- dev-libs/wayland
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtmultimedia:5
@@ -37,9 +36,10 @@ RDEPEND="
media-libs/libsdl2[sound,video]
net-libs/libpcap
net-libs/libslirp
+ wayland? ( dev-libs/wayland )
"
DEPEND="${RDEPEND}"
-BDEPEND="kde-frameworks/extra-cmake-modules:5"
+BDEPEND="wayland? ( kde-frameworks/extra-cmake-modules:5 )"
# used for JIT recompiler
QA_EXECSTACK="usr/bin/melonDS"
@@ -65,6 +65,7 @@ src_configure() {
-DBUILD_SHARED_LIBS=OFF
-DENABLE_JIT=$(usex jit)
-DENABLE_OGLRENDERER=$(usex opengl)
+ -DENABLE_WAYLAND=$(usex wayland)
)
cmake_src_configure
}