summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2021-11-26 11:01:13 +0100
committerMaciej Barć <xgqt@gentoo.org>2021-11-26 11:01:28 +0100
commitfc66d7d2a987626a597f05485a3ad5c0f06a638e (patch)
tree4e33111fbbf4bf58c23bd0c6edd1953f3018473b /games-emulation/melonds
parentdev-util/yamllint: initial import (diff)
downloadgentoo-fc66d7d2a987626a597f05485a3ad5c0f06a638e.tar.gz
gentoo-fc66d7d2a987626a597f05485a3ad5c0f06a638e.tar.bz2
gentoo-fc66d7d2a987626a597f05485a3ad5c0f06a638e.zip
games-emulation/melonds: new package; add version 0.9.3 and live
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'games-emulation/melonds')
-rw-r--r--games-emulation/melonds/Manifest1
-rw-r--r--games-emulation/melonds/melonds-0.9.3.ebuild83
-rw-r--r--games-emulation/melonds/melonds-9999.ebuild83
-rw-r--r--games-emulation/melonds/metadata.xml13
4 files changed, 180 insertions, 0 deletions
diff --git a/games-emulation/melonds/Manifest b/games-emulation/melonds/Manifest
new file mode 100644
index 000000000000..3a233230003e
--- /dev/null
+++ b/games-emulation/melonds/Manifest
@@ -0,0 +1 @@
+DIST melonDS-0.9.3.tar.gz 2241325 BLAKE2B 0ea7fbcce039a60a0553ae45d11f0b1550bfec2300faf1c99c3ee531bd5949c7293bec187fbf53e400bbb6280df29db141b2d1bcb294a8abf2eabb71993db686 SHA512 37f26f3a9784873ce1664645cea70049725367f5fe62f7c58842ebd5da2c73ffe423695dddb0ffd444bdf59df2a3fcd778cdf95b2bb083014b961fed282953f5
diff --git a/games-emulation/melonds/melonds-0.9.3.ebuild b/games-emulation/melonds/melonds-0.9.3.ebuild
new file mode 100644
index 000000000000..840aa5476022
--- /dev/null
+++ b/games-emulation/melonds/melonds-0.9.3.ebuild
@@ -0,0 +1,83 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NOTICE:
+# melonds bundles teakra, its upstream haven't had a release since 2020
+
+EAPI=8
+
+MY_PN="melonDS"
+MY_P="${MY_PN}-${PV}"
+
+inherit cmake flag-o-matic toolchain-funcs xdg
+
+DESCRIPTION="Nintendo DS emulator, sorta"
+HOMEPAGE="
+ http://melonds.kuribo64.net
+ https://github.com/Arisotura/melonDS
+"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Arisotura/${MY_PN}.git"
+else
+ SRC_URI="https://github.com/Arisotura/${MY_PN}/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+IUSE="+jit +opengl"
+LICENSE="BSD-2 GPL-2 GPL-3 Unlicense"
+SLOT="0"
+
+DEPEND="
+ app-arch/libarchive
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ media-libs/libsdl2[sound,video]
+ net-libs/libpcap
+ net-libs/libslirp
+ opengl? ( media-libs/libepoxy )
+"
+RDEPEND="${DEPEND}"
+
+# used for JIT recompiler
+QA_EXECSTACK="usr/bin/melonDS"
+
+src_prepare() {
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_JIT=$(usex jit)
+ -DENABLE_OGLRENDERER=$(usex opengl)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ tc-export AR
+ cmake_src_compile
+}
+
+src_install() {
+ # install teakra
+ dolib.so "${BUILD_DIR}/src/teakra/src/libteakra.so"
+
+ cmake_src_install
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ elog "You need the following files in order to run melonDS:"
+ elog "- bios7.bin"
+ elog "- bios9.bin"
+ elog "- firmware.bin"
+ elog "- romlist.bin"
+ elog "Place them in ~/.config/melonDS"
+ elog "Those files can be found somewhere on the Internet ;-)"
+}
diff --git a/games-emulation/melonds/melonds-9999.ebuild b/games-emulation/melonds/melonds-9999.ebuild
new file mode 100644
index 000000000000..840aa5476022
--- /dev/null
+++ b/games-emulation/melonds/melonds-9999.ebuild
@@ -0,0 +1,83 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NOTICE:
+# melonds bundles teakra, its upstream haven't had a release since 2020
+
+EAPI=8
+
+MY_PN="melonDS"
+MY_P="${MY_PN}-${PV}"
+
+inherit cmake flag-o-matic toolchain-funcs xdg
+
+DESCRIPTION="Nintendo DS emulator, sorta"
+HOMEPAGE="
+ http://melonds.kuribo64.net
+ https://github.com/Arisotura/melonDS
+"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Arisotura/${MY_PN}.git"
+else
+ SRC_URI="https://github.com/Arisotura/${MY_PN}/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+IUSE="+jit +opengl"
+LICENSE="BSD-2 GPL-2 GPL-3 Unlicense"
+SLOT="0"
+
+DEPEND="
+ app-arch/libarchive
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ media-libs/libsdl2[sound,video]
+ net-libs/libpcap
+ net-libs/libslirp
+ opengl? ( media-libs/libepoxy )
+"
+RDEPEND="${DEPEND}"
+
+# used for JIT recompiler
+QA_EXECSTACK="usr/bin/melonDS"
+
+src_prepare() {
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_JIT=$(usex jit)
+ -DENABLE_OGLRENDERER=$(usex opengl)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ tc-export AR
+ cmake_src_compile
+}
+
+src_install() {
+ # install teakra
+ dolib.so "${BUILD_DIR}/src/teakra/src/libteakra.so"
+
+ cmake_src_install
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ elog "You need the following files in order to run melonDS:"
+ elog "- bios7.bin"
+ elog "- bios9.bin"
+ elog "- firmware.bin"
+ elog "- romlist.bin"
+ elog "Place them in ~/.config/melonDS"
+ elog "Those files can be found somewhere on the Internet ;-)"
+}
diff --git a/games-emulation/melonds/metadata.xml b/games-emulation/melonds/metadata.xml
new file mode 100644
index 000000000000..598e25db79ba
--- /dev/null
+++ b/games-emulation/melonds/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/Arisotura/melonDS/issues</bugs-to>
+ <remote-id type="github">Arisotura/melonDS</remote-id>
+ </upstream>
+</pkgmetadata>