summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-01-05 15:09:45 +0200
committerDavid Seifert <soap@gentoo.org>2017-01-05 15:30:03 +0200
commit7ef4424f16e54d7c4b72d88b8c7bbc27d1394005 (patch)
treee813c5156546e23f65a6b6f13bac57786ce672e6 /games-emulation/nestopia/nestopia-1.47_p20170105.ebuild
parentnet-misc/knemo: amd64 stable wrt bug #604550 (diff)
downloadgentoo-7ef4424f16e54d7c4b72d88b8c7bbc27d1394005.tar.gz
gentoo-7ef4424f16e54d7c4b72d88b8c7bbc27d1394005.tar.bz2
gentoo-7ef4424f16e54d7c4b72d88b8c7bbc27d1394005.zip
games-emulation/nestopia: Add new snapshot
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'games-emulation/nestopia/nestopia-1.47_p20170105.ebuild')
-rw-r--r--games-emulation/nestopia/nestopia-1.47_p20170105.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/games-emulation/nestopia/nestopia-1.47_p20170105.ebuild b/games-emulation/nestopia/nestopia-1.47_p20170105.ebuild
new file mode 100644
index 000000000000..9e91e2bdec87
--- /dev/null
+++ b/games-emulation/nestopia/nestopia-1.47_p20170105.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils gnome2-utils
+
+DESCRIPTION="A portable Nintendo Entertainment System emulator written in C++"
+HOMEPAGE="http://0ldsk00l.ca/nestopia/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/rdanbrook/nestopia.git"
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/rdanbrook/${PN}/archive/d7fae2aff1a93eac997d2b480652a1d068a2b6cf.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="doc gui"
+
+RDEPEND="
+ app-arch/libarchive:=
+ media-libs/libao
+ media-libs/libepoxy
+ media-libs/libsdl2[sound,joystick,video]
+ sys-libs/zlib
+ gui? ( x11-libs/gtk+:3 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_GTK=$(usex gui)
+ -DENABLE_DOC=$(usex doc)
+ -DCMAKE_INSTALL_DOCDIR=share/doc/${PF}
+ )
+ cmake-utils_src_configure
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}