summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-12-28 21:00:41 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-12-28 21:04:10 -0500
commit8d20cc57acca57295f7b20b3313d83625d9947a7 (patch)
treebfaf5a7c46ff94f0c7d1637b2b4d96431c29ccc9 /games-emulation/pcsx2
parentdev-perl/MIME-Types: add github upstream metadata (diff)
downloadgentoo-8d20cc57acca57295f7b20b3313d83625d9947a7.tar.gz
gentoo-8d20cc57acca57295f7b20b3313d83625d9947a7.tar.bz2
gentoo-8d20cc57acca57295f7b20b3313d83625d9947a7.zip
games-emulation/pcsx2: update rapidyaml patch for live
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation/pcsx2')
-rw-r--r--games-emulation/pcsx2/files/pcsx2-1.7.3803-rapidyaml-0.5.0.patch63
-rw-r--r--games-emulation/pcsx2/pcsx2-9999.ebuild2
2 files changed, 64 insertions, 1 deletions
diff --git a/games-emulation/pcsx2/files/pcsx2-1.7.3803-rapidyaml-0.5.0.patch b/games-emulation/pcsx2/files/pcsx2-1.7.3803-rapidyaml-0.5.0.patch
new file mode 100644
index 000000000000..bded24136fe3
--- /dev/null
+++ b/games-emulation/pcsx2/files/pcsx2-1.7.3803-rapidyaml-0.5.0.patch
@@ -0,0 +1,63 @@
+Quick fix for >=0.5.0 (breaks <0.5.0)
+
+Upstream seem to have no intention to acknowledge this as an issue
+until they bump their bundled copy of rapidyaml:
+https://github.com/PCSX2/pcsx2/issues/7623#issuecomment-1357048378
+--- a/pcsx2/GameDatabase.cpp
++++ b/pcsx2/GameDatabase.cpp
+@@ -176,5 +176,5 @@
+ if (node.has_child("gameFixes") && node["gameFixes"].has_children())
+ {
+- for (const ryml::NodeRef& n : node["gameFixes"].children())
++ for (const ryml::ConstNodeRef& n : node["gameFixes"].children())
+ {
+ bool fixValidated = false;
+@@ -207,5 +207,5 @@
+ if (node.has_child("speedHacks") && node["speedHacks"].has_children())
+ {
+- for (const ryml::NodeRef& n : node["speedHacks"].children())
++ for (const ryml::ConstNodeRef& n : node["speedHacks"].children())
+ {
+ bool speedHackValidated = false;
+@@ -237,5 +237,5 @@
+ if (node.has_child("gsHWFixes"))
+ {
+- for (const ryml::NodeRef& n : node["gsHWFixes"].children())
++ for (const ryml::ConstNodeRef& n : node["gsHWFixes"].children())
+ {
+ const std::string_view id_name(n.key().data(), n.key().size());
+@@ -258,5 +258,5 @@
+ if (node.has_child("memcardFilters") && node["memcardFilters"].has_children())
+ {
+- for (const ryml::NodeRef& n : node["memcardFilters"].children())
++ for (const ryml::ConstNodeRef& n : node["memcardFilters"].children())
+ {
+ auto memcardFilter = std::string(n.val().str, n.val().len);
+@@ -268,5 +268,5 @@
+ if (node.has_child("patches") && node["patches"].has_children())
+ {
+- for (const ryml::NodeRef& n : node["patches"].children())
++ for (const ryml::ConstNodeRef& n : node["patches"].children())
+ {
+ // use a crc of 0 for default patches
+@@ -293,5 +293,5 @@
+ if (node.has_child("dynaPatches") && node["dynaPatches"].has_children())
+ {
+- for (const ryml::NodeRef& n : node["dynaPatches"].children())
++ for (const ryml::ConstNodeRef& n : node["dynaPatches"].children())
+ {
+ DynamicPatch patch;
+@@ -299,5 +299,5 @@
+ if (n.has_child("pattern") && n["pattern"].has_children())
+ {
+- for (const ryml::NodeRef& db_pattern : n["pattern"].children())
++ for (const ryml::ConstNodeRef& db_pattern : n["pattern"].children())
+ {
+ DynamicPatchEntry entry;
+@@ -307,5 +307,5 @@
+ patch.pattern.push_back(entry);
+ }
+- for (const ryml::NodeRef& db_replacement : n["replacement"].children())
++ for (const ryml::ConstNodeRef& db_replacement : n["replacement"].children())
+ {
+ DynamicPatchEntry entry;
diff --git a/games-emulation/pcsx2/pcsx2-9999.ebuild b/games-emulation/pcsx2/pcsx2-9999.ebuild
index 17916151687b..eebe34cc10de 100644
--- a/games-emulation/pcsx2/pcsx2-9999.ebuild
+++ b/games-emulation/pcsx2/pcsx2-9999.ebuild
@@ -128,7 +128,7 @@ src_prepare() {
# could depend on >=0.5 for unconditional, but rather not force it yet
# https://github.com/PCSX2/pcsx2/issues/7623
has_version '>=dev-cpp/rapidyaml-0.5' &&
- eapply "${FILESDIR}"/${PN}-1.7.3602-rapidyaml-0.5.0.patch
+ eapply "${FILESDIR}"/${PN}-1.7.3803-rapidyaml-0.5.0.patch
cmake_src_prepare