summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-09-19 06:37:42 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-09-19 07:35:33 -0400
commit1884641504f5a41851e1f6e0112ae097c4eb6e54 (patch)
treea48198cc7ebb7e9d41d675052e65067f9b13cd48 /games-emulation/pcsx2_patches
parentgames-emulation/pcsx2_patches: update install path (diff)
downloadgentoo-1884641504f5a41851e1f6e0112ae097c4eb6e54.tar.gz
gentoo-1884641504f5a41851e1f6e0112ae097c4eb6e54.tar.bz2
gentoo-1884641504f5a41851e1f6e0112ae097c4eb6e54.zip
games-emulation/pcsx2_patches: add 0_p20230917
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation/pcsx2_patches')
-rw-r--r--games-emulation/pcsx2_patches/Manifest1
-rw-r--r--games-emulation/pcsx2_patches/pcsx2_patches-0_p20230917.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/games-emulation/pcsx2_patches/Manifest b/games-emulation/pcsx2_patches/Manifest
index cfb4281bd4c5..e451dedc54e4 100644
--- a/games-emulation/pcsx2_patches/Manifest
+++ b/games-emulation/pcsx2_patches/Manifest
@@ -1 +1,2 @@
DIST pcsx2_patches-0_p20230822.tar.gz 618444 BLAKE2B a51bba04e4bd52f8d04e5529ce05c7d22cd550bd00a5268b29addba24ca45f9c248ba9a7012a54e0187dfd75c423748b09e3afdafdd421177e8b08cbfd4809e4 SHA512 8a8ae2ed4a4b5ebca9f8a9d0b12d6fb9c862bc68496f167dc02fac4c1b39767a9bd9ff84373e43484b7a06693b06f07f2e9b283d3ec3de0202807f46801ce190
+DIST pcsx2_patches-0_p20230917.tar.gz 622275 BLAKE2B 1c9bb048ae46d454e723828d762c1d084da17777c391b0fdb40a0d3b376560f3d67336cb50f6d65efe1c1b3ff3e2079c6fbca1de00ebbe62ff97d47d6b63a294 SHA512 35eacac2ab230d645b860f79be39b9f312a23b28c4fa69c67b710a89a78343e56dc1f0c1c4a128bc73dd57b6bec0438c1561e5277c6daad4dc4000d0123f91cb
diff --git a/games-emulation/pcsx2_patches/pcsx2_patches-0_p20230917.ebuild b/games-emulation/pcsx2_patches/pcsx2_patches-0_p20230917.ebuild
new file mode 100644
index 000000000000..0c6c6df7c915
--- /dev/null
+++ b/games-emulation/pcsx2_patches/pcsx2_patches-0_p20230917.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit python-any-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/PCSX2/pcsx2_patches.git"
+else
+ HASH_PCSX2_PATCHES=b270bd4298e8fa998eb28d8a5fb784a4820075e9
+ SRC_URI="
+ https://github.com/PCSX2/pcsx2_patches/archive/${HASH_PCSX2_PATCHES}.tar.gz
+ -> ${P}.tar.gz"
+ S=${WORKDIR}/${PN}-${HASH_PCSX2_PATCHES}
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Collection of game patches for use with PCSX2 (e.g. widescreen hacks)"
+HOMEPAGE="https://github.com/PCSX2/pcsx2_patches/"
+
+# these are normally distributed by upstream with PCSX2 which is GPL-3+
+LICENSE="GPL-3+"
+SLOT="0"
+
+BDEPEND="${PYTHON_DEPS}"
+
+src_compile() {
+ # upstream uses a constantly replaced "latest" patches.zip (currently no
+ # real releases), and github's .zip archives cannot be used either due to
+ # having the patches/ subdirectory -- so we use a snapshot and repack
+ # (could use app-arch/zip, but python is more likely to skip a dependency)
+ ebegin "Creating patches.zip"
+ "${PYTHON}" - <<-EOF
+ import pathlib
+ from zipfile import ZipFile, ZIP_DEFLATED
+
+ patches = pathlib.Path("patches/")
+
+ with ZipFile("patches.zip", "w", ZIP_DEFLATED, compresslevel=9) as archive:
+ for file in patches.iterdir():
+ archive.write(file, arcname=file.name)
+ EOF
+ eend ${?} || die
+}
+
+src_install() {
+ insinto /usr/lib/pcsx2/resources
+ doins patches.zip
+
+ einstalldocs
+}