summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-04-22 03:11:23 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-04-22 03:24:48 -0400
commit244fb11064cbb620172ab1151c6eaf0bdfea0289 (patch)
treeda8ac0b1ac03ac2c38f6c4ee2ee4b53c0825a626 /games-emulation/pcsx2_patches
parentgames-emulation/pcsx2_patches: stabilize 0_p20240312 for ALLARCHES (diff)
downloadgentoo-244fb11064cbb620172ab1151c6eaf0bdfea0289.tar.gz
gentoo-244fb11064cbb620172ab1151c6eaf0bdfea0289.tar.bz2
gentoo-244fb11064cbb620172ab1151c6eaf0bdfea0289.zip
games-emulation/pcsx2_patches: drop 0_p20231217, 0_p20240116
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation/pcsx2_patches')
-rw-r--r--games-emulation/pcsx2_patches/Manifest2
-rw-r--r--games-emulation/pcsx2_patches/pcsx2_patches-0_p20231217.ebuild55
-rw-r--r--games-emulation/pcsx2_patches/pcsx2_patches-0_p20240116.ebuild55
3 files changed, 0 insertions, 112 deletions
diff --git a/games-emulation/pcsx2_patches/Manifest b/games-emulation/pcsx2_patches/Manifest
index d3e22d52b0a0..920509682688 100644
--- a/games-emulation/pcsx2_patches/Manifest
+++ b/games-emulation/pcsx2_patches/Manifest
@@ -1,3 +1 @@
-DIST pcsx2_patches-0_p20231217.tar.gz 647767 BLAKE2B a82211d3a31ee3475d2047ad4c25cc247003b15f8132c0e0fa1c144fff3ea59f0806409aeb9a1128697aee2453110d2da50e9577067d068879a885477b04dc3a SHA512 411431fa80a0a221c7b336ebb84ce9b0c078ff75c2cc79b5e31c9b5fc505f9ecec8b371c142a6be6802e2070ae57758c65df34d24d5392fb9f4065a276b32610
-DIST pcsx2_patches-0_p20240116.tar.gz 657224 BLAKE2B 9a85ed98565fa002176b86675c60b016688959228b9055c7e577aea235d15a9aa64d09e4af7c997670dec075a3c3b790d19661342d2f5978ca49adc9da33625a SHA512 c35281bb92d562e279fe81c2584d8341b407a3bd72467825c4ac454a698cd844b905dd4533144c7837e22b1fb7971be525fc5dcd8f0ec09e5f1d66630f7c2692
DIST pcsx2_patches-0_p20240312.tar.gz 664671 BLAKE2B 3061297d147db103a24c7c20c81723fd0f602ec22b38ab12624816c812431ca7440d8dea15ada71e18fc3da480ddcee50a19bf2186274640f3f3dc264795b0b7 SHA512 400cde1c18e7bb2472ddecf96ae918830cbdc6d61fb12f392d0aeda6219f75cf597440c96c6ae1defaea4e2298925833548a473d3c7000f22e20dedbe0f401b7
diff --git a/games-emulation/pcsx2_patches/pcsx2_patches-0_p20231217.ebuild b/games-emulation/pcsx2_patches/pcsx2_patches-0_p20231217.ebuild
deleted file mode 100644
index 23effcddc10f..000000000000
--- a/games-emulation/pcsx2_patches/pcsx2_patches-0_p20231217.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 2023-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-inherit python-any-r1
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/PCSX2/pcsx2_patches.git"
-else
- HASH_PCSX2_PATCHES=42d7ee72b66955e3bbd2caaeaa855f605b463722
- SRC_URI="
- https://github.com/PCSX2/pcsx2_patches/archive/${HASH_PCSX2_PATCHES}.tar.gz
- -> ${P}.tar.gz
- "
- S=${WORKDIR}/${PN}-${HASH_PCSX2_PATCHES}
- KEYWORDS="amd64"
-fi
-
-DESCRIPTION="Collection of game patches for use with PCSX2 (e.g. widescreen hacks)"
-HOMEPAGE="https://github.com/PCSX2/pcsx2_patches/"
-
-# these are normally distributed by upstream with PCSX2 which is GPL-3+
-LICENSE="GPL-3+"
-SLOT="0"
-
-BDEPEND="${PYTHON_DEPS}"
-
-src_compile() {
- # upstream uses a constantly replaced "latest" patches.zip (currently no
- # real releases), and github's .zip archives cannot be used either due to
- # having the patches/ subdirectory -- so we use a snapshot and repack
- # (could use app-arch/zip, but python is more likely to skip a dependency)
- ebegin "Creating patches.zip"
- "${PYTHON}" - <<-EOF
- import pathlib
- from zipfile import ZipFile, ZIP_DEFLATED
-
- patches = pathlib.Path("patches/")
-
- with ZipFile("patches.zip", "w", ZIP_DEFLATED, compresslevel=9) as archive:
- for file in patches.iterdir():
- archive.write(file, arcname=file.name)
- EOF
- eend ${?} || die
-}
-
-src_install() {
- insinto /usr/lib/pcsx2/resources
- doins patches.zip
-
- einstalldocs
-}
diff --git a/games-emulation/pcsx2_patches/pcsx2_patches-0_p20240116.ebuild b/games-emulation/pcsx2_patches/pcsx2_patches-0_p20240116.ebuild
deleted file mode 100644
index adad6bafa8ff..000000000000
--- a/games-emulation/pcsx2_patches/pcsx2_patches-0_p20240116.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 2023-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-inherit python-any-r1
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/PCSX2/pcsx2_patches.git"
-else
- HASH_PCSX2_PATCHES=619e75bb8db50325b44863f2ccf3c39470c3d5a3
- SRC_URI="
- https://github.com/PCSX2/pcsx2_patches/archive/${HASH_PCSX2_PATCHES}.tar.gz
- -> ${P}.tar.gz
- "
- S=${WORKDIR}/${PN}-${HASH_PCSX2_PATCHES}
- KEYWORDS="amd64"
-fi
-
-DESCRIPTION="Collection of game patches for use with PCSX2 (e.g. widescreen hacks)"
-HOMEPAGE="https://github.com/PCSX2/pcsx2_patches/"
-
-# these are normally distributed by upstream with PCSX2 which is GPL-3+
-LICENSE="GPL-3+"
-SLOT="0"
-
-BDEPEND="${PYTHON_DEPS}"
-
-src_compile() {
- # upstream uses a constantly replaced "latest" patches.zip (currently no
- # real releases), and github's .zip archives cannot be used either due to
- # having the patches/ subdirectory -- so we use a snapshot and repack
- # (could use app-arch/zip, but python is more likely to skip a dependency)
- ebegin "Creating patches.zip"
- "${PYTHON}" - <<-EOF
- import pathlib
- from zipfile import ZipFile, ZIP_DEFLATED
-
- patches = pathlib.Path("patches/")
-
- with ZipFile("patches.zip", "w", ZIP_DEFLATED, compresslevel=9) as archive:
- for file in patches.iterdir():
- archive.write(file, arcname=file.name)
- EOF
- eend ${?} || die
-}
-
-src_install() {
- insinto /usr/lib/pcsx2/resources
- doins patches.zip
-
- einstalldocs
-}