summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-07-04 16:19:24 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-07-04 16:47:17 -0400
commit91f0a8ff5222df5e4d3f77b382854e400c114afc (patch)
tree25101bc8ec28e0a5e31a57ace9cefb47aea2a51c /games-emulation/zsnes
parentsys-apps/systemd-utils: do not install 70-power-switch.rules (diff)
downloadgentoo-91f0a8ff5222df5e4d3f77b382854e400c114afc.tar.gz
gentoo-91f0a8ff5222df5e4d3f77b382854e400c114afc.tar.bz2
gentoo-91f0a8ff5222df5e4d3f77b382854e400c114afc.zip
games-emulation/zsnes: add 2.0.10
Remember kids, don't use zsnes. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation/zsnes')
-rw-r--r--games-emulation/zsnes/Manifest1
-rw-r--r--games-emulation/zsnes/zsnes-2.0.10.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/games-emulation/zsnes/Manifest b/games-emulation/zsnes/Manifest
index eeb8097cf656..80fd70941d9b 100644
--- a/games-emulation/zsnes/Manifest
+++ b/games-emulation/zsnes/Manifest
@@ -1 +1,2 @@
+DIST zsnes-2.0.10.tar.gz 926347 BLAKE2B b9ab4701290ae802cb35045e0a3d4ff5268f96f7dc84614f39e950a6273a8477d5e2dca0598e3448744486de31caf692d44d36fe284f6f20697a5b4e92c908f8 SHA512 513e350198a944af47accedc6d3c14405898c753bb8168871d323c11f8c1253d8d7e247759a13e40a3b5eda195824e4862bb1fc093a3db9a75c8bb2e0bef728e
DIST zsnes-2.0.9.tar.gz 935183 BLAKE2B a9b72ed15b2ed6d9e4631b4f12b2291ddca76a7236da008eba0f8b3ee27c94b98f00ff16a4929929adf484bc16554474b942b9f8306f46ab713e8a40e1f64624 SHA512 ea9244e98a175db9bceddf14e8212b3474ddaba1f508d698d8cfc43270fa3dabf51dca43dd30255272aba3cd061bf450bef04e005ce8087d550400e66faea565
diff --git a/games-emulation/zsnes/zsnes-2.0.10.ebuild b/games-emulation/zsnes/zsnes-2.0.10.ebuild
new file mode 100644
index 000000000000..38c0c2f51af8
--- /dev/null
+++ b/games-emulation/zsnes/zsnes-2.0.10.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="Fork of the classic Super Nintendo emulator"
+HOMEPAGE="https://github.com/xyproto/zsnes/ https://www.zsnes.com/"
+SRC_URI="https://github.com/xyproto/zsnes/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="custom-cflags"
+
+RDEPEND="
+ media-libs/libglvnd[X,abi_x86_32(-)]
+ media-libs/libpng:=[abi_x86_32(-)]
+ media-libs/libsdl[abi_x86_32(-),joystick,opengl,sound,video]
+ sys-libs/zlib:=[abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="
+ dev-lang/nasm
+ sys-libs/zlib
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.9-cc-quotes.patch
+ "${FILESDIR}"/${PN}-2.0.9-gentoo-zlib.patch
+)
+
+src_compile() {
+ # Makefile forces many CFLAGS that are questionable, but zsnes' ancient x86
+ # asm is fragile, not pic safe (bug #427104), broken by F_S=3 (formerly
+ # broken with =2 as well), and can be affected by -march=* and similar.
+ # Stick to upstream's choices, this is non-portable either way.
+ if use !custom-cflags; then
+ strip-flags
+ append-cppflags -U_FORTIFY_SOURCE # to disable =3, Makefile enables =2
+ fi
+
+ # used to build and run parsegen at build time (uses zlib wrt BDEPEND)
+ tc-export_build_env BUILD_CXX
+ local buildcxx="${BUILD_CXX} ${BUILD_CXXFLAGS} ${BUILD_CPPFLAGS} ${BUILD_LDFLAGS}"
+
+ use amd64 && multilib_toolchain_setup x86
+ tc-export CC CXX
+ append-cflags "${CPPFLAGS}"
+ append-cxxflags "${CPPFLAGS}"
+
+ emake CXX_HOST="${buildcxx}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+
+ dodoc README.md TODO.md
+
+ newicon icons/64x64x32.png ${PN}.png
+ make_desktop_entry ${PN} ${PN^^}
+}