summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-09-10 14:03:46 -0400
committerMichael Sterrett <mr_bones_@gentoo.org>2015-09-10 14:03:46 -0400
commitf2a0fd366bf7ce4e16b92169a64c94cc465247ae (patch)
tree8e16f8252663554411b7d7cbbc022fe48d701138 /games-emulation/zsnes
parentkde5.eclass: Block old kde4-l10n for kde-{frameworks,plasma} (diff)
downloadgentoo-f2a0fd366bf7ce4e16b92169a64c94cc465247ae.tar.gz
gentoo-f2a0fd366bf7ce4e16b92169a64c94cc465247ae.tar.bz2
gentoo-f2a0fd366bf7ce4e16b92169a64c94cc465247ae.zip
don't depend on specific autotools behavior to build (bug #559766)
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'games-emulation/zsnes')
-rw-r--r--games-emulation/zsnes/files/zsnes-1.51-arch.patch77
-rw-r--r--games-emulation/zsnes/files/zsnes-1.51-stack-align.patch4
-rw-r--r--games-emulation/zsnes/zsnes-1.51-r4.ebuild8
3 files changed, 83 insertions, 6 deletions
diff --git a/games-emulation/zsnes/files/zsnes-1.51-arch.patch b/games-emulation/zsnes/files/zsnes-1.51-arch.patch
new file mode 100644
index 000000000000..2c8b690587be
--- /dev/null
+++ b/games-emulation/zsnes/files/zsnes-1.51-arch.patch
@@ -0,0 +1,77 @@
+--- configure.in.orig
++++ configure.in
+@@ -233,72 +233,8 @@
+ debug=no)
+ AC_MSG_CHECKING(if you want gdb friendly executable)
+ AC_MSG_RESULT($debug)
+-if test x$debug = xyes; then
+-dnl - It is easier to debug zsnes with no optimization enabled.
+- ZSNESEXE="zsnesd"
+- PSR_TEMP=""
+- CFLAGS="$CFLAGS -Wall -W -DDEBUG -O0 -fno-omit-frame-pointer -gstabs3"
+- NFLAGS="$NFLAGS -DDEBUG -g -F stabs -s -O0"
+-else
+- ZSNESEXE="zsnes"
+- PSR_TEMP=" rm -f t_\$*.c"
+-
+- CFLAGSBAK="$CFLAGS"
+- AC_ARG_VAR(force_arch, [Force architecture to optimize GCC/G++ for])
+- AC_MSG_CHECKING(which cpu architecture to optimize for)
+- if test x$force_arch != x; then
+- CFLAGS="$CFLAGS -march=$force_arch"
+- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]])],
+- [AC_MSG_RESULT(forcing $force_arch)],
+- [AC_MSG_RESULT($force_arch ??)
+- AC_MSG_WARN(incorrect force_arch parameter)
+- force_arch=""
+- CFLAGS="$CFLAGSBAK"
+- AC_MSG_CHECKING(for autodetected architecture)])
+- else
+- if test x$ARCH_INFO = x; then
+- case x$target in
+- i686-*-*)
+- AC_MSG_RESULT(guessing i686)
+- CFLAGS="$CFLAGS -march=i686"
+- ;;
+- i586-*-*)
+- AC_MSG_RESULT(guessing i586)
+- CFLAGS="$CFLAGS -march=i586"
+- ;;
+- i486-*-*)
+- AC_MSG_RESULT(guessing i486)
+- CFLAGS="$CFLAGS -march=i486"
+- ;;
+- *)
+- AC_MSG_RESULT(guessing i386)
+- CFLAGS="$CFLAGS -march=i386"
+- AC_MSG_WARN([This is not what you want, use --target or force-arch])
+- ;;
+- esac
+- else
+- AC_MSG_RESULT($ARCH_INFO)
+- CFLAGS="$CFLAGS -march=$ARCH_INFO"
+- fi
+- fi
+-
+- AC_ARG_ENABLE(release,
+- [ --enable-release Build ultra-optimized release binary (zsnes)],
+- release=$enableval,
+- release=no)
+- AC_MSG_CHECKING(if you want crazy optimizations)
+- AC_MSG_RESULT($release)
+- if test x$release = xyes; then
+- if test x$force_arch = x; then
+- AC_MSG_WARN([If you intend to distribute this binary, make sure you use force_arch and set to i586 (or whichever CPU Arch you intend for)])
+- fi
+- CFLAGS="$CFLAGS -O3 -fomit-frame-pointer -fprefetch-loop-arrays -fforce-addr $STRIP -D__RELEASE__"
+- NFLAGS="$NFLAGS -O99999999 -D__RELEASE__"
+- else
+- CFLAGS="$CFLAGS -O3 -fomit-frame-pointer $STRIP"
+- NFLAGS="$NFLAGS -O1"
+- fi
+-fi
++ZSNESEXE="zsnes"
++PSR_TEMP=" rm -f t_\$*.c"
+ CXXFLAGS="$CFLAGS -fno-rtti"
+
+ if test x$enable_jma != xno; then
diff --git a/games-emulation/zsnes/files/zsnes-1.51-stack-align.patch b/games-emulation/zsnes/files/zsnes-1.51-stack-align.patch
index e509e0107763..32136643caec 100644
--- a/games-emulation/zsnes/files/zsnes-1.51-stack-align.patch
+++ b/games-emulation/zsnes/files/zsnes-1.51-stack-align.patch
@@ -1,5 +1,5 @@
---- zsnes_1_51/src/linux/sdllink.c.old 2014-03-01 04:01:30.351323580 -0500
-+++ zsnes_1_51/src/linux/sdllink.c 2014-03-01 04:02:12.249702898 -0500
+--- zsnes_1_51/src/linux/sdllink.c.old
++++ zsnes_1_51/src/linux/sdllink.c
@@ -773,11 +773,11 @@ BOOL InitInput()
{
InitJoystickInput();
diff --git a/games-emulation/zsnes/zsnes-1.51-r4.ebuild b/games-emulation/zsnes/zsnes-1.51-r4.ebuild
index 0fedbe9ca3ab..1daadac483a7 100644
--- a/games-emulation/zsnes/zsnes-1.51-r4.ebuild
+++ b/games-emulation/zsnes/zsnes-1.51-r4.ebuild
@@ -49,7 +49,8 @@ src_prepare() {
"${FILESDIR}"/${P}-buffer.patch \
"${FILESDIR}"/${P}-gcc47.patch \
"${FILESDIR}"/${P}-stack-align.patch \
- "${FILESDIR}"/${P}-cross-compile.patch
+ "${FILESDIR}"/${P}-cross-compile.patch \
+ "${FILESDIR}"/${P}-arch.patch
# The sdl detection logic uses AC_PROG_PATH instead of
# AC_PROG_TOOL, so force the var to get set the way we
@@ -76,6 +77,7 @@ src_prepare() {
src_configure() {
tc-export CC
export BUILD_CXX=$(tc-getBUILD_CXX)
+ export NFLAGS=-O1
use amd64 && multilib_toolchain_setup x86
use custom-cflags || strip-flags
@@ -87,9 +89,7 @@ src_configure() {
$(use_enable png libpng) \
$(use_enable opengl) \
--disable-debug \
- --disable-cpucheck \
- --enable-release \
- force_arch=no
+ --disable-cpucheck
}
src_compile() {