summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2023-11-24 21:50:48 -0800
committerJohn Helmert III <ajak@gentoo.org>2023-11-24 21:56:28 -0800
commit4b2db08d75a54d5cc159ad03aee5df3e9579a41a (patch)
tree9eaf1db5ea48ef09c9d89ea11a7b290ca48a7c24 /games-emulation
parentnet-libs/liboauth: cleanup curl_ssl_nss cruft (diff)
downloadgentoo-4b2db08d75a54d5cc159ad03aee5df3e9579a41a.tar.gz
gentoo-4b2db08d75a54d5cc159ad03aee5df3e9579a41a.tar.bz2
gentoo-4b2db08d75a54d5cc159ad03aee5df3e9579a41a.zip
games-emulation/openmsx: add 19.1
Reported apparent CXXFLAGS handling regression below. Working around it with sed, as is already done with LDFLAGS. Add python3_12. See-Also: https://github.com/openMSX/openMSX/issues/1563 Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/openmsx/Manifest1
-rw-r--r--games-emulation/openmsx/openmsx-19.1.ebuild113
2 files changed, 114 insertions, 0 deletions
diff --git a/games-emulation/openmsx/Manifest b/games-emulation/openmsx/Manifest
index bceea346b609..66c03abdf711 100644
--- a/games-emulation/openmsx/Manifest
+++ b/games-emulation/openmsx/Manifest
@@ -1 +1,2 @@
DIST openmsx-18.0.tar.gz 4151084 BLAKE2B 0d5b4e4745c12689e4227408481367b4b4faaa4c7c2830ec0c4b9a5eb90c4b415628cd21834384d39fa4a820c725431848e98f7ef722c437f7bb4f96ae7b14c4 SHA512 f395fae8eac3bcb9334251c1c266a8c4d2951d6510a7c4885ddbc95aaed39f4ef8ae12a177d4a9ff44745ca368055f55f9983029b47441f4fd9731696f79809f
+DIST openmsx-19.1.tar.gz 4216833 BLAKE2B 7d1ed4dfb76d0d9d3eecf1447395b4bec775f6c92edf8164583de3b0fe9fc98bce00c47206340e2cde417ba5580785ec92be04ec7a6c5cf2f1a03cd5769ce746 SHA512 107208f7a9324beb348e8dd7f9ad878ee04ee3948159448065ff2a8c78a9c890e38cb2cbcada754bfc3698a6ba53b0ad1a9ac837d6071eb330b18ea2bdb0fbc7
diff --git a/games-emulation/openmsx/openmsx-19.1.ebuild b/games-emulation/openmsx/openmsx-19.1.ebuild
new file mode 100644
index 000000000000..ef83b43a1552
--- /dev/null
+++ b/games-emulation/openmsx/openmsx-19.1.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10,11,12} )
+
+inherit desktop flag-o-matic python-any-r1 readme.gentoo-r1 toolchain-funcs xdg
+
+DESCRIPTION="MSX emulator that aims for perfection"
+HOMEPAGE="https://openmsx.org/"
+SRC_URI="https://github.com/openMSX/openMSX/releases/download/RELEASE_${PV//./_}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+joystick"
+
+RDEPEND="dev-lang/tcl:0=
+ media-libs/alsa-lib
+ media-libs/harfbuzz:=
+ media-libs/libogg
+ media-libs/libpng:0=
+ media-libs/libsdl2[joystick=,sound,video]
+ media-libs/libtheora
+ media-libs/libvorbis
+ media-libs/sdl2-ttf
+ >=media-libs/glew-1.3.2:0=
+ sys-libs/zlib
+ virtual/opengl"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}"
+
+DOC_CONTENTS="
+If you want to if you want to emulate real MSX systems and not
+only the free C-BIOS machines, put the system ROMs in one of
+the following directories: /usr/share/${PN}/systemroms
+or ~/.openMSX/share/systemroms
+"
+
+src_prepare() {
+ default
+ sed -i \
+ -e '/^CXXFLAGS:=/d' \
+ -e '/^LDFLAGS:=/d' \
+ -e '/LINK_FLAGS_PREFIX/d' \
+ -e '/LINK_FLAGS+=/s/-s//' \
+ -e '/LINK_FLAGS+=\$(TARGET_FLAGS)/s/$/ $(LDFLAGS)/' \
+ build/main.mk \
+ || die
+ sed -i -e 's/-fsanitize=address//' build/flavour-unittest.mk || die
+ sed -i -e '/SYMLINK/s:true:false:' build/custom.mk || die
+ sed -i -e 's/GPL.txt//' doc/node.mk || die
+
+ # Build system only configured to use bundled version - but not from the
+ # directory it's distributed in
+ cp "${S}/Contrib/catch2/catch.hpp" "${S}/src/unittest" || die
+}
+
+src_configure() {
+ tc-export CXX
+
+ # Doesn't compile without this, and build system doesn't consistently add
+ # it properly for all compilers
+ append-cxxflags '-std=c++17'
+
+ default
+}
+
+src_compile() {
+ emake \
+ INSTALL_SHARE_DIR="${EPREFIX}/usr/share/${PN}" \
+ V=1
+}
+
+src_test() {
+ # To get tests, we need to build with OPENMSX_FLAVOUR=unittest and then the
+ # build is stored in a directory of the pattern
+ # ${WORKDIR}/derived/*-unittest/. This is separate from the actual build,
+ # stored in ${WORKDIR}/derived/*-opt. The unittest binary and the workdir
+ # binary are in each of these directories under their `bin` directories.
+ emake \
+ V=1 \
+ OPENMSX_FLAVOUR=unittest
+
+ # There will only ever be one *-unittest directory
+ "${S}"/derived/*-unittest/bin/openmsx || die
+}
+
+src_install() {
+ # To guarantee installing the proper binary in case tests were built,
+ # specify the default OPENMSX_FLAVOUR
+ emake \
+ V=1 \
+ INSTALL_BINARY_DIR="${ED}/usr/bin" \
+ INSTALL_SHARE_DIR="${ED}/usr/share/${PN}" \
+ INSTALL_DOC_DIR="${ED}/usr/share/doc/${PF}" \
+ OPENMSX_FLAVOUR=opt \
+ install
+
+ einstalldocs
+ readme.gentoo_create_doc
+
+ for i in 16 32 48 64 128 256 ; do
+ newicon -s "${i}" "share/icons/openMSX-logo-${i}.png" "${PN}.png"
+ done
+ make_desktop_entry "${PN}" "openMSX"
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+ xdg_pkg_postinst
+}