summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-13 11:27:04 +0100
committerDavid Seifert <soap@gentoo.org>2021-02-13 11:27:04 +0100
commit5795a8e8c8fd41b51cf7d284ec0b79b5cdc8b1c1 (patch)
tree8938deca69381ccec7d20acedf62a5c306c994c7 /games-emulation
parentdev-util/kernelshark: Remove old (diff)
downloadgentoo-5795a8e8c8fd41b51cf7d284ec0b79b5cdc8b1c1.tar.gz
gentoo-5795a8e8c8fd41b51cf7d284ec0b79b5cdc8b1c1.tar.bz2
gentoo-5795a8e8c8fd41b51cf7d284ec0b79b5cdc8b1c1.zip
games-emulation/lxdream: Port to EAPI 7
Closes: https://bugs.gentoo.org/740382 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/lxdream/files/lxdream-0.9.1-fno-common.patch12
-rw-r--r--games-emulation/lxdream/lxdream-0.9.1-r3.ebuild27
2 files changed, 27 insertions, 12 deletions
diff --git a/games-emulation/lxdream/files/lxdream-0.9.1-fno-common.patch b/games-emulation/lxdream/files/lxdream-0.9.1-fno-common.patch
new file mode 100644
index 000000000000..d325963eac28
--- /dev/null
+++ b/games-emulation/lxdream/files/lxdream-0.9.1-fno-common.patch
@@ -0,0 +1,12 @@
+https://bugs.gentoo.org/740382
+--- a/src/sh4/sh4trans.h
++++ b/src/sh4/sh4trans.h
+@@ -130,7 +130,7 @@ gboolean sh4_translate_flush_cache( void );
+ * Either returns immediately (to skip the breakpoint), or aborts the current
+ * cycle and never returns.
+ */
+-void FASTCALL sh4_translate_breakpoint_hit( sh4vma_t pc );
++extern void FASTCALL sh4_translate_breakpoint_hit( sh4vma_t pc );
+
+ #ifdef __cplusplus
+ }
diff --git a/games-emulation/lxdream/lxdream-0.9.1-r3.ebuild b/games-emulation/lxdream/lxdream-0.9.1-r3.ebuild
index 40c8736acefc..e4b53ffde512 100644
--- a/games-emulation/lxdream/lxdream-0.9.1-r3.ebuild
+++ b/games-emulation/lxdream/lxdream-0.9.1-r3.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
inherit flag-o-matic xdg
DESCRIPTION="An emulator for the Sega Dreamcast system"
-HOMEPAGE="http://www.lxdream.org/"
+HOMEPAGE="https://github.com/lxdream/lxdream"
SRC_URI="http://www.lxdream.org/count.php?file=${P}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
@@ -16,25 +17,27 @@ IUSE="debug profile pulseaudio sdl" #lirc
RDEPEND="
app-misc/lirc
-
media-libs/alsa-lib
media-libs/libpng:0=
- pulseaudio? ( media-sound/pulseaudio )
- sdl? ( media-libs/libsdl[sound] )
virtual/opengl
x11-libs/gtk+:2
-"
+ pulseaudio? ( media-sound/pulseaudio )
+ sdl? ( media-libs/libsdl[sound] )"
DEPEND="${RDEPEND}
+ !!gnustep-base/gnustep-gui" #377635
+BDEPEND="
virtual/pkgconfig
sys-devel/gettext
- virtual/os-headers
- !!gnustep-base/gnustep-gui" #377635
+ virtual/os-headers"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-glib-single-include.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+)
src_prepare() {
default
- eapply "${FILESDIR}/${PN}-0.9.1-glib-single-include.patch"
-
# Make .desktop file pass desktop-file-validate
sed -i \
-e '/Encoding/d' \
@@ -54,7 +57,7 @@ src_configure() {
# lirc configure option is not recognized
# $(use_with lirc) \
econf \
- --datadir="/usr/share" \
+ --datadir="${EPREFIX}/usr/share" \
$(use_enable debug trace) \
$(use_enable debug watch) \
$(use_enable profile profiled) \