summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-03-10 09:19:51 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-03-10 09:19:51 +0100
commit784141eaa303b718314b323f42b3b104c8936b17 (patch)
tree560226ab7a132f5890a15558bfb04640b53e199d /games-emulation
parentsys-libs/glibc: fix live ebuild link (diff)
downloadgentoo-784141eaa303b718314b323f42b3b104c8936b17.tar.gz
gentoo-784141eaa303b718314b323f42b3b104c8936b17.tar.bz2
gentoo-784141eaa303b718314b323f42b3b104c8936b17.zip
games-emulation/snes9x: Bump to version 1.60
Thanks-to: Alexander Tsoy <alexander@tsoy.me> Closes: https://bugs.gentoo.org/712014 Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/snes9x/Manifest1
-rw-r--r--games-emulation/snes9x/snes9x-1.60.ebuild128
2 files changed, 129 insertions, 0 deletions
diff --git a/games-emulation/snes9x/Manifest b/games-emulation/snes9x/Manifest
index 863925ff3184..4275f56091e4 100644
--- a/games-emulation/snes9x/Manifest
+++ b/games-emulation/snes9x/Manifest
@@ -1,2 +1,3 @@
DIST snes9x-1.58.tar.gz 2830667 BLAKE2B 66446e56a172b318f7cefecc59d927270377f725df0ca89888e1c50eb3f5475729ffc9da86ead5e50f106ab0781ad644ae3b3ed5719724db9b78b687135ead04 SHA512 51f8e92258db58e55f7b0b6c4537a916358891bb5ee35bd984d1970d2fedbdb2f8b3a4f560e0302d3011e521a1072c8a0d69723e8b151f61d33802c02f392d7d
DIST snes9x-1.59.2.tar.gz 2819803 BLAKE2B 3e077fe68dbc6ae9acf7625c1371971300cfb72143e0e98841dc8d75be5ccc45812d79d7810d28d1a5dc5c17a69cf0f9483e9c69e91437d864a4cbaf34852b35 SHA512 84d2dfc12a991b77b30ba9a591d285ecd4cc5fbb418282900209db9191d61611123ffa7d715b7abeed9b891e9af88ab4c46616502523a881127e2ede008236e4
+DIST snes9x-1.60.tar.gz 2863228 BLAKE2B 0ac3bdd2403221f1013e2b5438aacc4e7d361e943ac7edc56f8ef22827d81484e0b162b84f739ce0f68fe58021124275fd908ccdde99e1e1d6d6c9c0a6e3d17b SHA512 840b006a8fbd479fd5ceb2d94af4ef6470c5e27a3e6c8ddb0dffc8d3e51f465669144cd428bfce28b2ed4f68e70d8f252f2d8a2cae602ba797791d7e483c14c9
diff --git a/games-emulation/snes9x/snes9x-1.60.ebuild b/games-emulation/snes9x/snes9x-1.60.ebuild
new file mode 100644
index 000000000000..1460433e5d76
--- /dev/null
+++ b/games-emulation/snes9x/snes9x-1.60.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic meson xdg
+
+DESCRIPTION="Super Nintendo Entertainment System (SNES) emulator"
+HOMEPAGE="https://github.com/snes9xgit/snes9x"
+SRC_URI="https://github.com/snes9xgit/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Snes9x GPL-2 GPL-2+ LGPL-2.1 LGPL-2.1+ ISC MIT ZLIB Info-ZIP"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="alsa debug gtk multilib netplay opengl oss png pulseaudio portaudio wayland xinerama +xv"
+RESTRICT="bindist"
+
+RDEPEND="
+ sys-libs/zlib:=[minizip]
+ x11-libs/libX11
+ x11-libs/libXext
+ png? ( media-libs/libpng:0= )
+ gtk? (
+ dev-libs/glib:2
+ media-libs/libsdl2[joystick]
+ >=x11-libs/gtk+-3.22:3[wayland?]
+ x11-libs/libXrandr
+ x11-misc/xdg-utils
+ alsa? ( media-libs/alsa-lib )
+ opengl? (
+ media-libs/libepoxy
+ virtual/opengl
+ )
+ portaudio? ( >=media-libs/portaudio-19_pre )
+ pulseaudio? ( media-sound/pulseaudio )
+ xv? ( x11-libs/libXv )
+ wayland? ( dev-libs/wayland )
+ )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/${P}/unix"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.53-cross-compile.patch
+ "${FILESDIR}"/${PN}-1.59-build-system.patch
+)
+
+src_prepare() {
+ cd "${WORKDIR}/${P}" || die
+ rm -r unzip || die
+ default
+ cd unix || die
+ eautoreconf
+ if use gtk ; then
+ export EMESON_SOURCE="${WORKDIR}/${P}/gtk"
+ fi
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+
+ # build breaks when zlib/zip support is disabled
+ local myeconfargs=(
+ --enable-gamepad
+ --enable-gzip
+ --enable-zip
+ --with-system-zip
+ $(use_enable debug debugger)
+ $(use_enable netplay)
+ $(use_enable png screenshot)
+ $(use_enable xinerama)
+ )
+ econf "${myeconfargs[@]}"
+
+ if use gtk; then
+ local emesonargs=(
+ -Dalsa="$(usex alsa true false)"
+ -Ddebugger="$(usex debug true false)"
+ -Dgtk2=false
+ -Dgtk3=true
+ -Dopengl="$(usex opengl true false)"
+ -Doss="$(usex oss true false)"
+ -Dportaudio="$(usex portaudio true false)"
+ -Dpulseaudio="$(usex pulseaudio true false)"
+ -Dscreenshot="$(usex png true false)"
+ -Dsystem-zip=true
+ -Dxv="$(usex xv true false)"
+ -Dzlib=true
+ -Dwayland="$(usex wayland true false)"
+ )
+ meson_src_configure
+ fi
+}
+
+src_compile() {
+ emake
+ use gtk && meson_src_compile
+}
+
+src_install() {
+ dobin ${PN}
+
+ dodoc ../docs/{changes,control-inputs,controls,snapshots}.txt
+ dodoc snes9x.conf.default
+
+ if use gtk ; then
+ meson_src_install
+ dodoc ../gtk/AUTHORS
+ fi
+
+ docinto html
+ dodoc {.,..}/docs/*.html
+}
+
+pkg_preinst() {
+ use gtk && xdg_pkg_preinst
+}
+
+pkg_postinst() {
+ use gtk && xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ use gtk && xdg_pkg_postrm
+}