summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-03 20:34:09 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-04 10:37:21 +0100
commit7b39c6e5c4db51c5f45bb47a3e38d0da17ef95af (patch)
treee0665a5ce5c6e08888f9f76d783748602c5b92c8 /games-emulation
parentwww-client/epiphany: bump to 3.32.6 (diff)
downloadgentoo-7b39c6e5c4db51c5f45bb47a3e38d0da17ef95af.tar.gz
gentoo-7b39c6e5c4db51c5f45bb47a3e38d0da17ef95af.tar.bz2
gentoo-7b39c6e5c4db51c5f45bb47a3e38d0da17ef95af.zip
*/*: Switch games proj to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/hatari/hatari-2.2.1.ebuild8
-rw-r--r--games-emulation/vbam/vbam-2.1.4.ebuild6
-rw-r--r--games-emulation/vbam/vbam-9999.ebuild6
3 files changed, 10 insertions, 10 deletions
diff --git a/games-emulation/hatari/hatari-2.2.1.ebuild b/games-emulation/hatari/hatari-2.2.1.ebuild
index a8f84107c83e..7c7a695b755a 100644
--- a/games-emulation/hatari/hatari-2.2.1.ebuild
+++ b/games-emulation/hatari/hatari-2.2.1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python{2_7,3_{6,7}} )
-inherit cmake-utils python-single-r1 xdg
+inherit cmake python-single-r1 xdg
DESCRIPTION="Atari ST emulator"
HOMEPAGE="https://hatari.tuxfamily.org/"
@@ -48,7 +48,7 @@ DOCS=(
src_prepare() {
xdg_environment_reset
- cmake-utils_src_prepare
+ cmake_src_prepare
sed -i "s/\.1\.gz\b/.1/g;T;s/gzip[^\$]*/cat /g" {*/,}*/CMakeLists.txt || die
sed -i "s:\"doc\" + sep + \"hatari\":\"doc/${PF}\":" python-ui/uihelpers.py || die
@@ -71,10 +71,10 @@ src_configure() {
-DCMAKE_DISABLE_FIND_PACKAGE_Udev=$(usex !udev)
-DCMAKE_DISABLE_FIND_PACKAGE_ZLIB=$(usex !zlib)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
python_fix_shebang "${ED}"/usr/share/${PN}/
}
diff --git a/games-emulation/vbam/vbam-2.1.4.ebuild b/games-emulation/vbam/vbam-2.1.4.ebuild
index a8a2590c1f1e..b19935ad2686 100644
--- a/games-emulation/vbam/vbam-2.1.4.ebuild
+++ b/games-emulation/vbam/vbam-2.1.4.ebuild
@@ -4,7 +4,7 @@
EAPI=7
WX_GTK_VER="3.0-gtk3"
-inherit wxwidgets xdg cmake-utils
+inherit wxwidgets xdg cmake
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/visualboyadvance-m/visualboyadvance-m.git"
@@ -62,11 +62,11 @@ src_configure() {
-DENABLE_ASM_SCALERS=$(usex x86)
-DCMAKE_SKIP_RPATH=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
if use sdl ; then
dodoc doc/ReadMe.SDL.txt
diff --git a/games-emulation/vbam/vbam-9999.ebuild b/games-emulation/vbam/vbam-9999.ebuild
index f8607c8a0a0e..29f851e02f7b 100644
--- a/games-emulation/vbam/vbam-9999.ebuild
+++ b/games-emulation/vbam/vbam-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=7
WX_GTK_VER="3.0-gtk3"
-inherit wxwidgets xdg cmake-utils
+inherit wxwidgets xdg cmake
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/visualboyadvance-m/visualboyadvance-m.git"
@@ -58,11 +58,11 @@ src_configure() {
-DENABLE_ASM_SCALERS=$(usex x86)
-DCMAKE_SKIP_RPATH=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
if use sdl ; then
dodoc doc/ReadMe.SDL.txt