summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuel BAUER <samuel.bauer@yahoo.fr>2021-03-23 23:18:23 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-03-28 20:11:00 +0100
commit7daa88b5f535f881a587ccc6afaf3e46888520f3 (patch)
tree630d6b900e7a15e88bdef0555fbc7c6237f74eec /games-emulation
parentdev-python/pyglet: Remove old (diff)
downloadgentoo-7daa88b5f535f881a587ccc6afaf3e46888520f3.tar.gz
gentoo-7daa88b5f535f881a587ccc6afaf3e46888520f3.tar.bz2
gentoo-7daa88b5f535f881a587ccc6afaf3e46888520f3.zip
games-emulation/dolphin: refresh live ebuild
Avoid -durty suffix to allow more netplay sessions. Make vulkan-loader optional. Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/dolphin/dolphin-9999.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/games-emulation/dolphin/dolphin-9999.ebuild b/games-emulation/dolphin/dolphin-9999.ebuild
index 14b329e33b85..6bf77bf6c3d8 100644
--- a/games-emulation/dolphin/dolphin-9999.ebuild
+++ b/games-emulation/dolphin/dolphin-9999.ebuild
@@ -11,6 +11,7 @@ inherit cmake desktop xdg-utils l10n pax-utils
if [[ ${PV} == *9999 ]]
then
EGIT_REPO_URI="https://github.com/dolphin-emu/dolphin"
+ EGIT_SUBMODULES=()
inherit git-r3
else
inherit vcs-snapshot
@@ -69,7 +70,7 @@ BDEPEND="
# vulkan-loader required for vulkan backend which can be selected
# at runtime.
RDEPEND="${RDEPEND}
- media-libs/vulkan-loader"
+ vulkan? ( media-libs/vulkan-loader )"
src_prepare() {
cmake_src_prepare
@@ -131,8 +132,11 @@ src_prepare() {
l10n_find_plocales_changes "Languages/po/" "" '.po'
l10n_for_each_disabled_locale_do remove_locale
- # About 50% compile-time speedup
+ # About 50% compile-time speedup
use vulkan || sed -i -e '/Externals\/glslang/d' CMakeLists.txt
+
+ # Remove dirty suffix: needed for netplay
+ sed -i -e 's/--dirty/&=""/' CMakeLists.txt
}
src_configure() {