summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-06-25 23:09:54 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-06-25 23:13:21 -0400
commitab44d066809c6e8791afbaf828db5b7b846dad9b (patch)
treed90b6f423ed808264c1ceb2202c0139a2ce4101a /games-emulation
parentdev-python/semver: Keyword 2.13.0 arm64, #795966 (diff)
downloadgentoo-ab44d066809c6e8791afbaf828db5b7b846dad9b.tar.gz
gentoo-ab44d066809c6e8791afbaf828db5b7b846dad9b.tar.bz2
gentoo-ab44d066809c6e8791afbaf828db5b7b846dad9b.zip
games-emulation/desmume: fix openal automagic
There's a meson option to seemingly enable/disable openal, but in reality only flips its "required" state and it's used anyway if found. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/desmume/desmume-0.9.11_p20210409-r1.ebuild (renamed from games-emulation/desmume/desmume-0.9.11_p20210409.ebuild)2
-rw-r--r--games-emulation/desmume/files/desmume-0.9.11_p20210409-openal-automagic.patch10
2 files changed, 12 insertions, 0 deletions
diff --git a/games-emulation/desmume/desmume-0.9.11_p20210409.ebuild b/games-emulation/desmume/desmume-0.9.11_p20210409-r1.ebuild
index 752de42b7cbf..c3a847606182 100644
--- a/games-emulation/desmume/desmume-0.9.11_p20210409.ebuild
+++ b/games-emulation/desmume/desmume-0.9.11_p20210409-r1.ebuild
@@ -35,7 +35,9 @@ DEPEND="
PATCHES=(
"${FILESDIR}"/${P}-fix-gtk-cliopts.patch
+ "${FILESDIR}"/${P}-openal-automagic.patch
)
+
DOCS=( ${PN}/{AUTHORS,ChangeLog,README,README.LIN,doc/.} )
src_configure() {
diff --git a/games-emulation/desmume/files/desmume-0.9.11_p20210409-openal-automagic.patch b/games-emulation/desmume/files/desmume-0.9.11_p20210409-openal-automagic.patch
new file mode 100644
index 000000000000..565ea3f5a7b0
--- /dev/null
+++ b/games-emulation/desmume/files/desmume-0.9.11_p20210409-openal-automagic.patch
@@ -0,0 +1,10 @@
+Option only changes whether the dep is required and doesn't disable it.
+--- a/desmume/src/frontend/posix/meson.build
++++ b/desmume/src/frontend/posix/meson.build
+@@ -176,5 +176,5 @@
+ endif
+
+-if dep_openal.found()
++if dep_openal.found() and get_option('openal')
+ dependencies += dep_openal
+ libdesmume_src += [