summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-08 10:44:10 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-08 11:54:19 +0200
commitb73bfddaea9607d05525bb371a7f953b2165e981 (patch)
tree9742f05d9599b8422fdb7ca3858eba92c55e8774 /games-emulation
parentgames-emulation/dolphin: Add missing ||die (diff)
downloadgentoo-b73bfddaea9607d05525bb371a7f953b2165e981.tar.gz
gentoo-b73bfddaea9607d05525bb371a7f953b2165e981.tar.bz2
gentoo-b73bfddaea9607d05525bb371a7f953b2165e981.zip
games-emulation/dolphin: Remove vcs-snapshot.eclass
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/dolphin/dolphin-5.0_p20210506-r1.ebuild6
-rw-r--r--games-emulation/dolphin/dolphin-9999.ebuild8
2 files changed, 7 insertions, 7 deletions
diff --git a/games-emulation/dolphin/dolphin-5.0_p20210506-r1.ebuild b/games-emulation/dolphin/dolphin-5.0_p20210506-r1.ebuild
index ac9393e5df3d..3cf993b7b213 100644
--- a/games-emulation/dolphin/dolphin-5.0_p20210506-r1.ebuild
+++ b/games-emulation/dolphin/dolphin-5.0_p20210506-r1.ebuild
@@ -10,9 +10,9 @@ then
EGIT_REPO_URI="https://github.com/dolphin-emu/dolphin"
inherit git-r3
else
- inherit vcs-snapshot
- commit=eb5cd9be78c76b9ccbab9e5fbd1721ef6876cd68
- SRC_URI="https://github.com/dolphin-emu/dolphin/archive/${commit}.tar.gz -> ${P}.tar.gz"
+ EGIT_COMMIT=eb5cd9be78c76b9ccbab9e5fbd1721ef6876cd68
+ SRC_URI="https://github.com/dolphin-emu/dolphin/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S=${WORKDIR}/${PN}-${EGIT_COMMIT}
KEYWORDS="~amd64 ~arm64"
fi
diff --git a/games-emulation/dolphin/dolphin-9999.ebuild b/games-emulation/dolphin/dolphin-9999.ebuild
index 29779609bc0d..1fc6ba66f6bc 100644
--- a/games-emulation/dolphin/dolphin-9999.ebuild
+++ b/games-emulation/dolphin/dolphin-9999.ebuild
@@ -11,10 +11,10 @@ then
EGIT_SUBMODULES=( Externals/mGBA/mgba )
inherit git-r3
else
- inherit vcs-snapshot
- commit=0dbe8fb2eaa608a6540df3d269648a596c29cf4b
- SRC_URI="https://github.com/dolphin-emu/dolphin/archive/${commit}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
+ EGIT_COMMIT=eb5cd9be78c76b9ccbab9e5fbd1721ef6876cd68
+ SRC_URI="https://github.com/dolphin-emu/dolphin/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S=${WORKDIR}/${PN}-${EGIT_COMMIT}
+ KEYWORDS="~amd64 ~arm64"
fi
DESCRIPTION="Gamecube and Wii game emulator"