summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-30 20:12:17 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-31 19:42:20 +0100
commitbe0ab352405aa2d5d968a8c3905557b914df9626 (patch)
tree5b5da6a6ab8feb0c82b1f5c6b02e9fafdee83463 /games-emulation
parentsys-kernel/gentoo-sources: Linux patch 5.4.7 (diff)
downloadgentoo-be0ab352405aa2d5d968a8c3905557b914df9626.tar.gz
gentoo-be0ab352405aa2d5d968a8c3905557b914df9626.tar.bz2
gentoo-be0ab352405aa2d5d968a8c3905557b914df9626.zip
*/*: Switch proxy-maint to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/pcsx2/pcsx2-1.4.0-r2.ebuild6
-rw-r--r--games-emulation/pcsx2/pcsx2-9999.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/games-emulation/pcsx2/pcsx2-1.4.0-r2.ebuild b/games-emulation/pcsx2/pcsx2-1.4.0-r2.ebuild
index d31cad3370ad..11e3f7bd7c96 100644
--- a/games-emulation/pcsx2/pcsx2-1.4.0-r2.ebuild
+++ b/games-emulation/pcsx2/pcsx2-1.4.0-r2.ebuild
@@ -4,7 +4,7 @@
EAPI=7
MY_PV="${PV/_/-}"
-inherit cmake-utils multilib wxwidgets
+inherit cmake multilib wxwidgets
DESCRIPTION="A PlayStation 2 emulator"
HOMEPAGE="https://www.pcsx2.net"
@@ -77,11 +77,11 @@ src_configure() {
)
WX_GTK_VER="3.0" setup-wxwidgets
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
# Upstream issue: https://github.com/PCSX2/pcsx2/issues/417
QA_TEXTRELS="usr/$(get_libdir)/pcsx2/* usr/bin/PCSX2"
- cmake-utils_src_install
+ cmake_src_install
}
diff --git a/games-emulation/pcsx2/pcsx2-9999.ebuild b/games-emulation/pcsx2/pcsx2-9999.ebuild
index c0a277f41a05..f5e4931ead16 100644
--- a/games-emulation/pcsx2/pcsx2-9999.ebuild
+++ b/games-emulation/pcsx2/pcsx2-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils git-r3 multilib toolchain-funcs wxwidgets
+inherit cmake git-r3 multilib toolchain-funcs wxwidgets
DESCRIPTION="A PlayStation 2 emulator"
HOMEPAGE="https://www.pcsx2.net"
@@ -83,7 +83,7 @@ src_configure() {
)
WX_GTK_VER="3.0-gtk3" setup-wxwidgets
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
@@ -92,5 +92,5 @@ src_install() {
# https://github.com/PCSX2/pcsx2/issues/3077
QA_EXECSTACK="usr/bin/PCSX2"
QA_TEXTRELS="usr/$(get_libdir)/pcsx2/* usr/bin/PCSX2"
- cmake-utils_src_install
+ cmake_src_install
}