summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-09-17 00:14:18 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-09-17 00:23:39 -0400
commitcdb771bfd674ceca39e808f36da55b6b75867dd8 (patch)
tree935c2da1a28286d162e7a1a546e884c1232d7697 /games-emulation
parentapp-emulation/wine-staging: add 8.16 (diff)
downloadgentoo-cdb771bfd674ceca39e808f36da55b6b75867dd8.tar.gz
gentoo-cdb771bfd674ceca39e808f36da55b6b75867dd8.tar.bz2
gentoo-cdb771bfd674ceca39e808f36da55b6b75867dd8.zip
games-emulation/pcsx2: update live
Upstream purged some options and made them hard-required, did not use most of these but dbus is one of. Also adjust some comments. Things got changed around X11_API a bit, but seems it still tries to link with libX11 if (UNIX) regardless, so still no optional X (given upstream is killing options that they "do not test" once they get a build failure report, odds are it will remain this way). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/pcsx2/pcsx2-9999.ebuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/games-emulation/pcsx2/pcsx2-9999.ebuild b/games-emulation/pcsx2/pcsx2-9999.ebuild
index f2a78ab73686..bb34c0a768df 100644
--- a/games-emulation/pcsx2/pcsx2-9999.ebuild
+++ b/games-emulation/pcsx2/pcsx2-9999.ebuild
@@ -24,7 +24,7 @@ LICENSE="
ISC LGPL-2.1+ LGPL-3+ MIT OFL-1.1 ZLIB public-domain
"
SLOT="0"
-IUSE="alsa cpu_flags_x86_sse4_1 dbus jack pulseaudio sndio test vulkan wayland"
+IUSE="alsa cpu_flags_x86_sse4_1 jack pulseaudio sndio test vulkan wayland"
REQUIRED_USE="cpu_flags_x86_sse4_1" # dies at runtime if no support
RESTRICT="!test? ( test )"
@@ -40,11 +40,11 @@ COMMON_DEPEND="
media-video/ffmpeg:=
net-libs/libpcap
net-misc/curl
+ sys-apps/dbus
sys-libs/zlib:=
virtual/libudev:=
x11-libs/libXrandr
alsa? ( media-libs/alsa-lib )
- dbus? ( sys-apps/dbus )
jack? ( virtual/jack )
pulseaudio? ( media-libs/libpulse )
sndio? ( media-sound/sndio:= )
@@ -97,20 +97,18 @@ src_configure() {
append-flags -fno-strict-aliasing
# odr violations in pcsx2's vulkan code, disabling as a safety for now
- # (vulkan support tend to receive major changes, is more on WIP side)
filter-lto
fi
local mycmakeargs=(
-DBUILD_SHARED_LIBS=no
- -DDBUS_API=$(usex dbus)
-DDISABLE_BUILD_DATE=yes
-DENABLE_TESTS=$(usex test)
-DUSE_LINKED_FFMPEG=yes
-DUSE_VTUNE=no
-DUSE_VULKAN=$(usex vulkan)
-DWAYLAND_API=$(usex wayland)
- -DX11_API=yes # fails if X libs are missing even if disabled
+ -DX11_API=yes # X libs are currently hard-required either way
# sse4.1 is the bare minimum required, -m is required at build time
# (see PCSX2Base.h) and it dies if no support at runtime (AppInit.cpp)