summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-11-26 23:40:38 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-11-27 00:15:35 -0500
commitd2b2beabf1fb184106dc3b8eab5f8163ce96641c (patch)
treefb833430c62637cca9b2aee3e2d7ea7be1d8945f /games-emulation
parentdev-python/jupyterlab-lsp: Bump to 5.0.1 (diff)
downloadgentoo-d2b2beabf1fb184106dc3b8eab5f8163ce96641c.tar.gz
gentoo-d2b2beabf1fb184106dc3b8eab5f8163ce96641c.tar.bz2
gentoo-d2b2beabf1fb184106dc3b8eab5f8163ce96641c.zip
games-emulation/pcsx2: update live
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/pcsx2/files/pcsx2-1.7.5232-cubeb-automagic.patch31
-rw-r--r--games-emulation/pcsx2/pcsx2-9999.ebuild2
2 files changed, 32 insertions, 1 deletions
diff --git a/games-emulation/pcsx2/files/pcsx2-1.7.5232-cubeb-automagic.patch b/games-emulation/pcsx2/files/pcsx2-1.7.5232-cubeb-automagic.patch
new file mode 100644
index 000000000000..e195ae79c3b1
--- /dev/null
+++ b/games-emulation/pcsx2/files/pcsx2-1.7.5232-cubeb-automagic.patch
@@ -0,0 +1,31 @@
+Same that media-libs/cubeb does and meant for -DLAZY_LOAD_LIBS=no.
+
+Unfortunately need to use bundled cubeb here given it modifies the
+source starting with (but not likely limited to):
+https://github.com/PCSX2/pcsx2/commit/9170a5abc1
+--- a/3rdparty/cubeb/CMakeLists.txt
++++ b/3rdparty/cubeb/CMakeLists.txt
+@@ -76,3 +76,5 @@
+
++ if(CHECK_PULSE)
+ pkg_check_modules(libpulse IMPORTED_TARGET libpulse)
++ endif()
+ if(libpulse_FOUND)
+@@ -83,3 +85,5 @@
+
++ if(CHECK_ALSA)
+ pkg_check_modules(alsa IMPORTED_TARGET alsa)
++ endif()
+ if(alsa_FOUND)
+@@ -90,3 +94,5 @@
+
++ if(CHECK_JACK)
+ pkg_check_modules(jack IMPORTED_TARGET jack)
++ endif()
+ if(jack_FOUND)
+@@ -97,3 +103,5 @@
+
++ if(CHECK_SNDIO)
+ check_include_files(sndio.h USE_SNDIO)
++ endif()
+ if(USE_SNDIO)
diff --git a/games-emulation/pcsx2/pcsx2-9999.ebuild b/games-emulation/pcsx2/pcsx2-9999.ebuild
index c2e6420ddbfc..7978166a40b3 100644
--- a/games-emulation/pcsx2/pcsx2-9999.ebuild
+++ b/games-emulation/pcsx2/pcsx2-9999.ebuild
@@ -70,9 +70,9 @@ BDEPEND="
"
PATCHES=(
- "${FILESDIR}"/${PN}-1.7.3468-cubeb-automagic.patch
"${FILESDIR}"/${PN}-1.7.3773-lto.patch
"${FILESDIR}"/${PN}-1.7.4667-flags.patch
+ "${FILESDIR}"/${PN}-1.7.5232-cubeb-automagic.patch
)
src_prepare() {